OLEobject

The OLEobject block lets you embed existing objects from files or insert new blank objects and create the information right in your diagram.

By embedding information in a VisSim diagram, you gain fast access to the functionality of another application without having to return to that application each time you want to make a change.

The technique of embedding is simple: just insert a file into your diagram. The inserted file is called an object, and appears as an OLEobject block in your diagram. When you embed an object, all of the instructions used to create the object are encapsulated and inserted in the OLEobject block along with it. The instructions include the objectís file format, the application used to create the object, and all of the information about how to display it. You donít see this information, but the application uses it to display and edit the object.

Embedding makes editing and updating the object quick and easy. You can just double-click on the OLEobject block in the VisSim diagram to open the object in its source application. Then you make your changes and close the file, and the object you embedded is updated automatically.

Embed existing objects

  1. Choose Blocks > OLEobject and click the mouse in the VisSim workarea.
    The Insert Object dialog appears.
    #########
  2. Activate the Create from File option.
  3. Click on the Browse button to find the object to be embedded in your VisSim diagram.
  4. Click on the OK button, or press enter.

Embed a new object

  1. Choose Blocks > OLEobject and click the mouse in the VisSim workarea.
    The Insert Object dialog appears.
    #########
  2. Activate the Create New option.
  3. In the Object Type list box, select the type of object you want to insert. For Mathcad 2000 documents, click on Mathcad Document
  4. Choose the OK button, or press enter.

Edit and update objects

You can edit an embedded objects directly from VisSim, or you can invoke the application as a separate, stand-alone program. To update the embedded object and return to the VisSim environment, simply click outside the OLEobject block.

To edit an embedded object directly from VisSim

  1. Do one of the following:
  2. From the drop-down menu, choose Object > Edit.
  3. VisSim opens a window with the application file.
  4. Make the changes you want.
  5. Click outside the embedded object to update the object and return to VisSim.

To invoke the object as a stand-alone application

  1. Click the right mouse button on the embedded object.
  2. From the drop-down menu, choose Object > Open.
  3. A stand-alone window is opened with the application file.
  4. Make the changes you want.
  5. To update the object and return to VisSim, do the following:
  6. Choose File > Update
  7. Choose File > Exit and Return to.

Examine the properties of an embedded object

The Properties dialog box lists the size of your embedded object, and allows you to control the general appearance of the document in your VisSim diagram. You can also use the Properties dialog box to scale the corresponding embedded object. This feature is described under Scale and crop OLEobject blocks.

To access general information about an embedded object
You can display the size and location of the embedded object.

  1. Click right mouse button over the embedded object.
  2. In the drop-down menu, choose Properties.
  3. The Properties dialog box appears.
  4. Click on the General tab.

To control the appearance of an embedded object
You can display the size and location of the embedded objectt.

  1. Click right mouse button over the embedded objectt.
  2. In the drop-down menu, choose Properties.
  3. The Properties dialog box appears.
  4. Click on the View tab.
  5. Do the following:
To Do this
Display the contents of the embedded object Activate the Display As Editable Information option.
Display an icon Activate the Display As Icon option. Click on the Change Icon button to select the type of icon to be displayed.
  1. Click on the OK button.

Scale and crop OLEobject blocks

You can resize an OLEobject block by scaling or cropping it. When you scale an OLEobject block, the text within the block is also scaled. When the dimensions of the OLEobject block are much larger than the text, you can adjust the size of the block by cropping its sides. The size of the text within the block is not affected by this action.

To scale an OLEobject block manually

  1. Click on the OLEobject block.
  2. Position the pointer over one of the handles on the block.
  3. Hold down the mouse button and drag until the block is the size you want.
  4. Click outside the OLEobject block to return to VisSim.

To scale an OLEobject block using the Properties dialog box

  1. Click right mouse button over the OLEobject block.
  2. In the drop-down menu, choose Properties.
  3. The Properties dialog box appears.
  4. Click on the View tab.

To scale the block with respect to its original size, activate the Relative To Original Size option.

  1. In the Scale box, select the scaling factor.
  2. Click on the Apply button to preview the new size.
  3. Click on the OK button to make the change permanent.

To crop an OLEobject block manually

  1. Double-click on OLEobject block.
  2. Position the pointer over one of the handles on the block.
  3. Hold down the mouse button and drag until the block is the size you want.
  4. Click outside the OLEobject block to return to VisSim.

To reset the size of an OLEobject block
You can use this method when you cropped the OLEobject block or when you scaled in manually.

  1. Click the right mouse button on the OLEobject block.
  2. From the drop-down menu, choose Reset Size.

Examples

Embedding an existing PowerPoint file

  1. In VisSim, insert an OLEobject block.
  2. In the Insert Object dialog box, do the following: