Работа с большими блок-схемами

Создание иерархической блок-схемы

Для удобства работы с большими блок-схемами в VisSim-е имеется возможность объединения некой совокупности блоков в одном составном. Использование составных блоков позволяет создать многоуровневое иерархическое представление блок-схемы. На верхнем уровне составные блоки могут отражать главные компоненты системы и их связи. На нижних уровнях в составных блоках может быть отображена логика работы каждого компонента и его частей.

Составные блоки позволяют применить модульный подход при разработке большой модели. Те. проектирование и проверка функционально независимых компонентов может быть выполнена независимо, и в разных рабочих файлах. Затем, используя внедряющий блок "блок-схема" или команду меню Файл > Вставить (Вставка vsm-файлов), Вы можете собрать все компоненты системы в итоговой блок-схеме.

Количество иерархических уровней в составном блоке может быть любым. Оно ограничено только ресурсами вашей системы. Если ваш составной блок содержит приватную информацию, Вы можете ограничить доступ к блоку, см. раздел: Защита составных блоков.

Рекомендуется назначать уникальные имена составным блокам, тогда у Вас будет возможность быстрого поиска блока по его имени. Для назначения имени следует воспользоваться командой меню Правка > Свойства блока, см. раздел: Установка параметров блоков.

Создание составного блока

При создании составного блока VisSim добавляет ему выводы:

Для создания составного блока выполните действия:

  1. Выделите блоки, которые Вы желаете объединить в составном.
  2. Выберите команду меню Правка > Создать составной блок. Появится диалоговое окно "Свойства составного блока".
  3. Введите имя составного блока. Избегайте использования символа точки (.) в имени. VisSim использует точку, чтобы отделить имя составного блока от имени файла в заголовке окна. По умолчанию назначается имя "Compound" (Составной).
  4. Нажмите на кнопку OK или клавишу ENTER.

Переходы по составным блокам

Если Вы перемещаетесь по блок-схеме, переходя из одного составного блока в другой, то VisSim добавляет их имена к имени рабочего файла в заголовке окна, и Вы можете отслеживать, где находитесь.

Для перехода внутрь составного блока выполните действия:

  1. Позиционируйте указатель мыши над составным блоком.
  2. Нажмите другую кнопку мыши.
  3. Если составной блок защищен паролем, то введите его в диалоговом окне "Password", и нажмите на кнопку OK или клавишу ENTER. Составной блок останется разблокированным, до тех пор, пока Вы не закроете рабочий файл.

Диалоговое окно ввода пароля для разблокирования защищенного составного блока

Для перехода из составного блока на внешний уровень выполните действия:

  1. Позиционируйте указатель мыши над свободным участком рабочего поля блок-схемы.
  2. Нажмите другую кнопку мыши.

Диалоговое окно настроек составного блока

Вы можете создать диалоговое окно настроек для любого составного блока. Оно позволяет централизовано, без потребности перехода внутрь блока менять параметры локализованной блок-схемы и устанавливать в ней начальные условия.

Для создания диалогового окна настроек составного блока выполните действия:

  1. Установите блоки константаДиалога внутри составного блока для генерации параметров и начальных условий.
  2. В свойствах блоков константаДиалога установите тип данных, генерируемое значение по умолчанию, и определите имя соответствующего параметра или начального условия.
  3. Вызовите диалоговое окно "Свойства составного блока" (CTRL + другая кнопка мыши). Активируйте опцию "Создать диалог для настройки блока".

После выполнения этих действий, если Вы вызовите диалоговое окно настроек составного блока (другой кнопкой мыши), то в нем появятся: имена всех его параметров и начальных условий; и в зависимости от типа данных соответствующих блоков константаДиалога будут выведены либо строки ввода, либо списки выбора, в которых будут отображены текущие значения.

Таким образом, поскольку для настроек составного блока отпадает необходимость переходить внутрь - можно ограничивать доступ паролем. Тип данных сократит вероятность случайных или неуместных изменений другими пользователями.

Использование блоков 'константаДиалога' для создания диалогового окна настроек составного блока

Если Вы создаете диалоговое окно настроек составного блока, то для его формирования Вы можете использовать требуемое (любое) количество блоков константаДиалога. Они имеют три параметра: "Имя", "Тип" (данных), и "Значение" - которые влияют на представление соответствующего параметра составного блока или начального условия в диалоговом окне настроек. VisSim автоматически корректирует размер диалогового окна настроек так, чтобы разместить данные от всех блоков константаДиалога.

Блок константаДиалога находится в меню "Блоки" в группе "Генераторы", устанавливается и подключается к блок-схеме обычным образом.

Для определения параметров блока константаДиалога выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой блок константаДиалога, параметры которого Вы хотите редактировать. Должно появится диалоговое окно "Константа для диалогового окна".
  3. Осуществите требуемые изменения.
  4. Нажмите на кнопку OK или клавишу ENTER.

диалоговое окно 'Константа для диалогового окна'

Быстрый доступ к параметрам блока константаДиалога возможен посредствам простого указания блока с помощью другой клавиши мыши.

Параметр блока 'константаДиалога'

Описание

Имя

Текст, введенный в этой строке ввода, будет отображаться при вызове диалогового окна настроек составного блока. Рядом с текстом будет либо строка ввода, либо переключатель, либо список выбора

Тип

В этом списке выбора следует установить тип генерируемой блоком константаДиалога величины: "Double" - число с плавающей точкой двойной точности, "Integer List" - целочисленные значения (0, 1, 2, ...) - номера строк в списке выбора, "Boolean" - логическая величина, принимающая значение 0 или 1.

Имеется два последствия выбора того или иного типа генерируемой величины:

  1. Вы должны по разному уточнить генерируемые по умолчанию значения.
  2. Рядом с текстом, в диалоговом окне настроек составного блока будет либо строка ввода, либо переключатель, либо список выбора.

Спроектированное диалоговое окно настроек составного блока

Значение

В этой строке или списке ввода Вы должны определить генерируемые по умолчанию значения.

  • Если тип величины "Double", то Вы должны ввести значение по правилам ввода чисел с плавающей точкой.
  • Если тип величины "Integer List", то Вы должны ввести список поясняющих текстовых строк.
  • Если тип величины "Boolean", то Вы должны ввести либо 0 либо 1. Единица активирует переключатель в диалоговом окне настроек составного блока, те в нем будет отображаться галочка

Правила инкапсуляции блоков 'константаДиалога' в составном блоке

При инкапсуляции блоков константаДиалога в составном блоке действуют следующие правила:

О порядке создания составного блока см. раздел: Создание составного блока.

Включение обработчика вызова диалогового окна настроек составного блока

Для включения обработчика вызова диалогового окна настроек составного блока, Вы должны активировать опцию "Создать диалог для настройки блока" в диалоговом окне "Свойства составного блока" (CTRL + другая кнопка мыши). После активации этой опции переход внутрь составного блока с помощью мыши не возможен. Его можно осуществить с помощью фреймового окна иерархии рабочей блок схемы. Активация упомянутой опции невозможна, если в составном блоке нет блоков константаДиалога.

Другая кнопка мыши может либо перевести Вас внутрь составного блока (для редактирования блок-схемы), либо отображать диалоговое окно его настроек (нельзя попасть внутрь и редактировать). Для смены процедуры обработки другой кнопки мыши выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой составной блок, с которым работаете. Должно появится диалоговое окно "Свойства составного блока".
  3. В зависимости от желаемой процедуры обработки другой клавиши мыши активируйте или деактивируйте опцию "Создать диалог для настройки блока".
  4. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Свойства составного блока'

Интерфейсы ввода значений в диалоговом окне настроек составного блока

Диалоговое окно настроек составного блока может взаимодействовать с множеством блоков константаДиалога. Однако типов данных, которые будут генерироваться блоками константаДиалога - три. На рисунке, в диалоговом окне показаны соответствующие интерфейсы для ввода значений.

Спроектированное диалоговое окно настроек составного блока

Тип данных блока константаДиалога Double Boolean Integer List
Интерфейс ввода значений Строка ввода Независимый переключатель Список выбора
Генерируемые значения число с плавающей точкой двойной точности 0 - выключено
1- включено
0, 1, 2, ...
Назначение Ввод параметров и начальных условий Включение и отключение опций в модели Переключение режимов в модели
Имя демонстрирующего блока константаДиалога Боковой ветер Форсаж Центр масс

Внешняя синхронизация составных блоков

Составные блоки в программе VisSim можно синхронизировать внешним сигналом. Этот механизм подобен внешней синхронизации обычного осциллографа. Синхровход отмечается красным или зеленым кругом. Если значение на синхровходе больше или равно 1, то VisSim выполняет вычисления для всех внутренних блоков. Если значение на синхровходе менее 1, то VisSim вычислений внутри составного блока не выполняет, а для внешних вычислений принимаются значения полученные в предыдущий момент синхронизации. Эта возможность помогает сократить время симуляции блок-схем систем с явно выраженными НЧ и ВЧ устройствами. Главное отличие внешней синхронизации от возможности назначить локальный временной шаг симуляции составному блоку (внутренняя синхронизация) состоит в том, что можно организовать многочастотную синхронизацию. На рисунке, показано, что при увеличении скорости изменения модулирующего сигнала частота синхронизации увеличивается - точность симуляции возрастает.

Стробирование составных блоков синтезирующих сигналы с НЧ спектром

Для активации или деактивации (скрытия) синхровхода составного блока выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой составной блок, с которым работаете. Должно появится диалоговое окно "Свойства составного блока".
  3. В зависимости от потребности активируйте или деактивируйте опцию "Вход синхронизации".
  4. Нажмите на кнопку OK или клавишу ENTER.

Внутренняя временная синхронизация составных блоков - Локальный шаг времени

Составным блокам в программе VisSim можно назначить локальный шаг времени больший, чем шаг симуляции. Те затраты вычислительных ресурсов для инкапсулированной части блок-схемы будут сокращены. Отличие от внешней синхронизации состоит в том, что организовать многочастотное временное квантование нельзя. Если на данном шаге симуляции VisSim не выполняет вычислений внутри составного блока, то для внешних вычислений принимаются значения полученные в предыдущий момент синхронизации. На рисунке показана симуляция движения (с разным локальным шагом времени) трех инкапсулированных в составных блоках колебательных звеньев с одинаковым затуханием и разными резонансными круговыми частотами 2,5; 6,3; 25 рад/с. При изменении временного масштаба осциллографа можно заметить, что переходные процессы подобны (красная и синяя осциллограммы). Так же можно наблюдать, что на периоде локального шага выходное значение составного блока не меняется.

Использование 'Локального шага времени' для повышения скорости симуляции и построения систем с многочастотной дискретизацией

Для активации или деактивации локального шага времени для составного блока выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой составной блок, с которым работаете. Должно появится диалоговое окно "Свойства составного блока".
  3. В зависимости от потребности активируйте или деактивируйте опцию "Локальный шаг времени" и уточните его величину в строке ввода.
  4. Нажмите на кнопку OK или клавишу ENTER.

Информация о количестве блоков в составном блоке

Если Вы хотите знать какое количество блоков инкапсулировано в составном, то Вам следует вызвать его диалоговое окно свойств. В нем имеется информация, как об общем количестве блоков, так и о количестве вычислительных.

Дисплей оператора - Скрытие составных блоков

VisSim может быть использован для создания "Дисплея оператора". Блок-схема в одноименном режиме выполняет функцию обработки сигналов (координат) и не должна быть видна. Только инструменты визуализации должны выполнять основное назначение (те должны быть видимы). В индивидуальном порядке, для каждого составного блока Вы можете активировать опцию, которая заставит VisSim скрыть их в режиме "Дисплея оператора".

Для скрытия или визуализации составных блоков в режиме "Дисплей оператора" выполните действия:

  1. Если режим "Дисплей оператора" активирован, то временно отключите его (команда меню Вид > Дисплей оператора).
  2. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  3. Укажите мышкой составной блок, с которым работаете. Должно появится диалоговое окно "Свойства составного блока".
  4. В зависимости от потребности активируйте или деактивируйте опцию "Скрыть в режиме Дисплей оператора".
  5. Нажмите на кнопку OK или клавишу ENTER.
  6. Активируйте режим "Дисплей оператора" - команда меню Вид > Дисплей оператора.

Изображения на составных блоках

Отображение любого составного блока можно изменить, подключив подходящую по смыслу картинку - bmp-файл формата растровой графики. Картинку Вы можете либо создать графическим редактором типа Paint, либо выбрать из коллекции VisSim-а, которая постоянно находится в директории ... VISSIM\BITMAP\DIAGRAM. О коллекции этих изображений см. Приложение E в Руководстве пользователя программы VisSim.

Для подключения или отключения картинки отображаемой на составном блоке выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой составной блок, с которым работаете. Должно появится диалоговое окно "Свойства составного блока".
  3. Если Вы желаете подключить картинку, то нажмите в поле "Картинка" на кнопку "Выбрать файл". Появится диалоговое окно выбора файла с bmp-фильтром. Выберите файл.
  4. Если Вы хотите отключить картинку, то деактивируйте в поле "Картинка" опцию "Подключить" и восстановите текстовое имя составного блока.
  5. Нажмите на кнопку OK или клавишу ENTER.

Восстановление искаженных bmp-изображений

Точечные рисунки могут отображаться искаженно в следующих случаях:

Метки выводов составных блоков

Демонстрация имен выводов у составного блокаДля качественного оформления блок-схем рекомендуется назначать идентифицирующие метки выводам составных блоков. Они становятся, видимы, если активирован режим отображения, включаемый командой меню Вид > Метки выводов. Кроме того, метки будут появляться слевой и справой сторон экрана внутри составных блоков рядом с внешними соединителями. А так же при снятии значений координат, с выводов посредствам другой кнопки мыши.

Каждый вывод в блок-схеме может принадлежать классу соединений и иметь собственную метку. Если Вы не определяете метку, но все же присваиваете вывод классу соединений, то имя класса будет отображаться на месте метки вывода.

Для назначения метки выводу блока выполните действия:

  1. Подведите указатель мыши к выводу. Вид указателя должен смениться на стрелку Данный вид указателя мыши сообщает о возможности работы с выводом блока.
  2. Осуществите двойной щелчок мышью - должен появиться диалог "Настройка выводов / соединений" (может мешать большой радиус авто-соединения).
  3. В строке ввода "Метка вывода" введите соответствующий текст.
  4. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройка выводов / соединений'

Если Вы хотите, увидеть метку на блоке, то активизируйте соответствующий режим отображения (команда меню Вид > Метки выводов). См. так же раздел: Создание классов соединений.

Распаковка составного блока

При пересмотре иерархии блок-схемы возникает потребность распаковки составных блоков. Если Вы выполняете соответствующую команду, то все содержимое, локализованное в указанном Вами составном блоке, без каких либо изменений появиться на текущем уровне. Те. внутренние составные блоки не будут распакованы. При этом все содержимое блока остается выделенным на случай, если Вы раздумаете, и вновь примите решение вернуть блок-схему в исходное состояние. Все межблочные соединения не разрываются.

Для распаковки составного блока выполните действия:

  1. Выберите команду меню Правка > Распаковать составной блок (курсор мыши сменится на распаковывающие стрелки).
  2. Укажите мышкой составной блок, который желаете распаковать.
  3. Щелкните мышкой на пустом месте рабочей блок-схемы для выхода из команды или продолжите операцию в отношении других составных блоков.

Цветовое оформление составных блоков

Все составные блоки могут быть либо черно-белые, либо могут быть окрашены в цвет морской волны.

Для смены цветового оформления всех составных блоков выполните действия:

  1. Выберите команду меню Правка > Настройки.
  2. Выберите вкладку "Глобальные настройки среды".
  3. Активируйте или деактивируйте опцию "Цветные составные блоки".
  4. Нажмите на кнопку OK или клавишу ENTER.

Блок внедрения

Посредствам библиотечного блока с именем блок-схема Вы можете выполнять распределенный по файлам проект. Очевидно, что некоторые компоненты разрабатываемых систем или системы повторяются. Например, ПИД-регулятор, типовые динамические звенья, функции оценки качества и пр. Они могут быть вынесены в отдельные файлы. Далее, с помощью блока с именем блок-схема, их можно многократно внедрять в любые уровни итогового файла проекта. Если Вы приходите к выводу, что внедренный блок требует коррекции, и выполняете ее в исходном файле, то изменения будут действительны во всех точках подключения этого файла к проекту. Выполнять коррекцию исходного файла через внедряющий блок с именем блок-схема нельзя. Исходный файл может иметь блокировку от просмотра содержимого.

Подготовка внедряемой блок-схемы

vsm-Файлы (блок-схемы), которые Вы планируете внедрять как составные компоненты в более сложные проекты с помощью блока с именем блок-схема, должны быть скомпонованы в соответствии с правилами:

Внедрение блок-схемы

Внедрение vsm-файла с помощью блока с именем блок-схема в более сложный проект, по сути, есть установка "пустого" блока, который вместо выполнения математических преобразований создает связи к внедряемому vsm-файлу. Если vsm-файл, внедренный в блок-схему верхнего уровня, будет потерян, то работоспособность ее нарушится.

Для внедрения vsm-файла в рабочую блок-схему выполните действия:

  1. Откройте блок-схему и переместитесь на иерархический уровень, где хотите внедрить подготовленный vsm-файл.
  2. Установите на рабочее поле библиотечный блок, имеющий имя блок-схема.
  3. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  4. Укажите мышкой блок внедрения. Должно появится диалоговое окно "Внедрение файла в блок".
  5. Нажмите на кнопку "Выбрать файл". Должно появиться диалоговое окно для выбора файла с vsm-фильтром.
  6. Укажите внедряемый файл, и нажмите кнопку ОК. Указанное имя vsm-файла появится в строке ввода "Имя" диалогового окна "Внедрение файла в блок".
  7. Нажмите на кнопку OK или клавишу ENTER.

Редактирование внедренной блок-схемы

Если vsm-файл, внедренный Вами с помощью блока с именем блок-схема, требует коррекции структуры, то для ее выполнения необходимо открыть исходный vsm-файл. Выполнять его коррекцию через внедряющий блок нельзя. Внесенные изменения будут действительны во всех точках внедрения.

В течение сеанса работы с проектом, для одинаковых внедренных блок-схем Вы можете устанавливать разные значения параметров и начальных условий, проникая внутрь к блокам внедренного vsm-файла или пользуясь подготовленным заранее диалоговым окном настроек составного блока. Однако вносимые изменения будут актуальны только до момента выхода из VisSim-а. Те параметры и начальные условия в рабочем файле для внедренной блок схемы сохранены не будут. Таким образом, механизм внедрения предполагает постоянство параметров и начальных условий у внедряемых фрагментов. Можно обойти это ограничение, увеличив количество входов для их передачи по проводникам.

Восстановление связей к внедренной блок-схеме

Если vsm-файл, который Вы внедряли в другие блок-схемы, будет перемещен или переименован, то связи с ним от точек внедрения будут нарушены. Об этом факте Вы будете предупреждены сообщениями, при попытке загрузить файл с нарушенными связями. В этом случае во всех точках внедрения Вам следует восстановить связи, корректируя либо путь к внедряемому файлу, либо его имя.

Для восстановления связи к внедренному vsm-файлу выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой блок внедрения. Должно появится диалоговое окно "Внедрение файла в блок".
  3. В строке ввода "Имя" введите правильный путь и имя vsm-файла. Для облегчения ввода Вы можете вызвать диалоговое окно выбора файла одноименной кнопкой.
  4. Нажмите на кнопку OK или клавишу ENTER.

Вставка vsm-файлов

При проектировании новых блок-схем можно использовать возможность быстрой их компоновки из совокупности отлаженных ранее проектов (из vsm-файлов). Для этой цели используется команда меню Файл > Вставить. Отличие вставки файлов от внедрения состоит в том, что все вставляемое содержимое копируется в текущую блок-схему и сохраняется в рабочем файле. Оно не должно иметь специального иерархического оформления и может быть как угодно модифицировано в дальнейшем.

Для вставки vsm-файла в рабочую блок-схему выполните действия:

  1. Откройте блок-схему и переместитесь на иерархический уровень, где хотите вставить vsm-файл.
  2. Выберите команду меню Файл > Вставить. Должно появиться диалоговое окно выбора файла с vsm-фильтром.
  3. Укажите вставляемый файл. Его имя должно появится в строке ввода "Имя файла". Если файл был снабжен описанием, то оно появится в нижней части окна.
  4. Нажмите на кнопку OK или клавишу ENTER. К указателю мыши прицепиться прямоугольная область с пунктирной границей отображающая площадь, которую занимает вставляемая блок-схема.
  5. Позиционируйте прямоугольную область над пустым полем рабочей блок-схемы в точке вставки.
  6. Нажмите кнопку мыши.

Передача сигналов переменными

Загромождение блок-схем проводниками можно исключить, применяя блок переменная, который позволяет передавать сигналы в VisSim-е альтернативным способом. Наиболее близким подобием является символ заземления в электрических принципиальных схемах. Имя передаваемого сигнала (имя переменной) отображается на каждом блоке переменная (на рис. показано определение и использование переменной 'Время'). В блок-схеме Вы можете определить любое количество переменных.

Образец использования блока 'переменная'

Каждый блок переменная имеет один вход и один выход. Однако если в блок-схеме установлено несколько блоков переменная (для передачи одного сигнала), то только на один из них этот сигнал может быть подан. Именно в этом блоке переменная будет определяться. На выходы всех блоков сигнал будет поступать без изменений. С одного выхода блока переменная сигнал может быть распределен на любое количество входов.

Создание переменных

Блок переменная Вы найдете в меню Блоки, в группе Аннотационные. При объявлении переменных настоятельно не рекомендуется использовать имена 'X'; '1', '2', '3', ... Причина состоит в том, что отображение в блок-схеме переменной 'X' будет конфликтовать с отображением блока инверсии знака сигнала -X, а отображение переменных с именами '1', '2', '3', ... будет конфликтовать с отображениями блоков константа и коэффУсиления.

Диалоговое окно для работы с переменными

Для определения имени переменной во вновь установленном блоке переменная выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой блок переменная, с которым работаете. Должно появится диалоговое окно "Выбор/создание переменной".
  3. Введите имя переменной, выполнив подходящую последовательность действий:
  4. Нажмите на кнопку OK или клавишу ENTER.

Видимость переменных

VisSim имеет механизм локализации переменных подобный тому, который существует в языках программирования высокого уровня. Видимость переменных может быть ограничена Вами. Имеются три области видимости:

Глобальная переменная может быть определена и использована в любом месте блок-схемы, те на любом иерархическом уровне.

Переопределяемая переменная может быть определена на любом уровне блок-схемы, а использована или переопределена на нижних, по ветви иерархии. Имя переопределяемой переменной должно начинаться с двух символов двоеточия, например, "::Omega".

Локальная переменная может быть определена и использована только на текущем уровне иерархии блок-схемы. Имя локальной переменной должно начинаться с символа двоеточия, например, ":Tay".

Локальные переменные

Локальная переменная может быть определена и использована только на текущем уровне иерархии блок-схемы. Ссылка на нее в других областях не имеет смысла - значение передано не будет. Локальная переменная максимально локализована - в этом есть несколько ключевых преимуществ:

Демонстрация применения 'Переменных уровня'

Имя локальной переменной должно начинаться с символа двоеточия, например, ":Tay".

Переопределяемые переменные

Переопределяемая переменная может быть определена на любом уровне блок-схемы, а использована или переопределена на нижних, по ветви иерархии. Ссылка на нее в других ветвях дерева иерархии не имеет смысла - значение передано не будет. Объявление переопределяемой переменной на верхнем иерархическом уровне делает ее и глобальной и переопределяемой, что требует особого внимания в виду высокой вероятности ошибочного переопределения. Рекомендуемая область применения - это составные блоки. Имя переопределяемой переменной должно начинаться с двух символов двоеточия, например, "::Omega".

Демонстрация применения 'Локальных переменных'

Демонстрация применения 'Локальных переменных'

На рисунках переопределяемая переменная "::k1" демонстрирует эффект локализации, переменная "::k" - механизм переопределения. Внутри составных блоков, к входу и выходам подключены соответствующие переменные.

Глобальные переменные

Глобальная переменная может быть определена и использована в любом месте блок-схемы, те на любом иерархическом уровне. Вам следует в последнюю очередь рассматривать возможность применения этих переменных, т.к.:

Хорошими примерами использования глобальных переменных являются решения о распределении по блок-схеме: констант (например, ускорения свободного падения), или же единого синхросигнала для дискретной системы.

Если Вы будете создавать копии составных блоков, в которых используются и определяются значения глобальных переменных, то VisSim автоматически переименует их следующим образом:

Имя_исходной_переменной@уникальный_номер

Поиск места определения переменной

Для поиска места определения переменной в блок-схеме выполните любую последовательность действий:

Поиск ссылок на переменную

Для поиска мест ссылок на переменную в блок-схеме выполните любую последовательность действий:

Встроенные переменные

VisSim имеет несколько встроенных переменных, которые можно использовать при создании блок-схем.

Встроенная переменная

Описание

$firstPass

Генерирует импульс единичной амплитуды на первом шаге симуляции

$lastPass

Генерирует импульс единичной амплитуды на последнем шаге симуляции

$randomSeed

Переменная хранит инициирующее число для Random-генератора, которое устанавливается Вами в диалоговом окне "Настройки симуляции" на вкладке "Предпочтения"

$runCount

Переменная хранит номер текущей симуляции в режиме повторных моделирований (в режиме Авто-рестарта), который используется для подбора или изучения влияний вариаций параметров

$timeStart

Переменная хранит начальное время симуляции

$timeStep

Переменная хранит величину шага симуляции

$timeStop

Переменная хранит конечное время симуляции

Использование псевдонимов для рабочих каталогов

Ваш vsm-проект может состоять из совокупности файлов. VisSim имеет гибкий механизм для назначения или смены рабочих каталогов. Этот нестандартный механизм предполагает описание текстовых переменных (псевдонимов), которым присваивается абсолютный путь к рабочим каталогам. Те при ссылке на файлы в проекте, допустимо указывать не пути, а псевдонимы. Можно определить несколько псевдонимов: для каталога растровых bmp-изображений, для внедряемых vsm-файлов, для map-файлов (файлы для определения нелинейных функций), для импортируемых файлов данных.

Типы псевдонимов пути

VisSim различает глобальные и локальные псевдонимы путей к рабочим каталогам. Глобальные псевдонимы хранятся в файле vissim.ini и актуальны для любой блок-схемы. Локальные псевдонимы хранятся в файле конкретной блок-схемы и актуальны только для нее.

Активация предупреждений о конфликтах определения псевдонимов пути

Допустима ситуация, когда локальный и глобальный псевдонимы пути имеют одинаковое имя. Локальный псевдоним имеет более высокий приоритет и будет использован. Однако Вы можете активировать соответствующие предупреждения.

Для активации предупреждений о конфликтах имен при определении локального и глобального псевдонимов пути выполните действия:

  1. Выберите команду меню Правка > Настройки.
  2. В диалоговом окне выберите вкладку "Глобальные настройки среды".
  3. Активизируйте опцию "Предупреждение о конфликтах определения псевдонимов".
  4. Нажмите на кнопку OK или клавишу ENTER.

Создание псевдонимов пути

Создать псевдонимы путей к рабочим каталогам можно посредствам диалогового окна вызываемого командой меню Правка > Настройки. Глобальные псевдонимы пути определяются на вкладке "Глобальные псевдонимы директорий"; локальные - на вкладке "Псевдонимы директорий блок-схемы". При выборе этих вкладок Вы увидите либо пустой, либо частично заполненный список определений псевдонимов. У Вас есть возможность либо редактировать его, либо пополнить.

Для создания псевдонима пути выполните действия:

  1. Выберите команду меню Правка > Настройки.
  2. В диалоговом окне выберите необходимую вкладку:
  3. Для дополнения списка "Псевдоним=директория", дважды щелкните мышью по многоточию.
  4. Введите псевдоним пути, придерживаясь формата: Псевдоним=путь_MS_DOS. Псевдоним не может содержать запятую (,), точку с запятой (;), двоеточие (:) и знак доллара ($). Имя пути должно быть определено в соответствии с правилами MS/DOS для диска, каталога и имени файла. Примеры см. в таблице.
  5. Нажмите на кнопку OK или клавишу ENTER.

Для изменения псевдонима пути выполните действия:

  1. Откройте проект (vsm-файл), который Вы переместили в другую директорию.
  2. Выберите команду меню Правка > Настройки.
  3. В диалоговом окне выберите необходимую вкладку:
  4. Для коррекции элемента списка "Псевдоним=директория", дважды щелкните по нему мышью.
  5. Отредактируйте псевдоним пути, придерживаясь формата: Псевдоним=путь_MS_DOS. Псевдоним не может содержать запятую (,), точку с запятой (;), двоеточие (:) и знак доллара ($). Имя пути должно быть определено в соответствии с правилами MS/DOS для диска, каталога и имени файла. Примеры см. в таблице.
  6. Нажмите на кнопку OK или клавишу ENTER.

Образец определения псевдонима

Пояснения

BmpDir=C:\BITMAPS\PUMP.BMP

Этот псевдоним пути определен, верно, и указывает на определенный файл

BmpDir=C:\BITMAPS

Этот псевдоним пути определен, верно, и указывает на директорию. При его использовании в блок-схеме имя этого псевдонима и имя файла необходимо отделять обратной наклонной чертой

BmpDir=C:\BITMAPS\

Этот псевдоним пути определен, верно, и указывает на директорию. При его использовании в блок-схеме его имя надо указывать в круглых скобках - (BmpDir)

$BmpDir=C:\BITMAPS

Этот псевдоним пути определен неверно - символ доллара недопустимо использовать в имени псевдонима

Указание псевдонимов пути в блоках

Использовать глобальные и локальные псевдонимы пути можно в любом блоке, который ссылается на файл. При этом псевдониму обязательно должен предшествовать символ доллара ($). Он используется, дабы VisSim мог различать, где пользователь указал MS_DOS-путь, а где использовал псевдоним.

Для создания в блоке ссылки на файл с применением псевдонима пути выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой блок, для которого необходимо создать ссылку на файл.
  3. В диалоговом окне Свойств, установите курсор в строке ввода имени файла (Имя файла, Имя, Имя составного блока, Растровое изображение, Изображение).
  4. Введите псевдоним пути, и, при необходимости, дополните его относительной частью ссылки на файл. Примеры см. в таблице. Обратите внимание, что если Вы не указываете диск при определении псевдонима, то VisSim использует текущий для поиска файла.
  5. Нажмите на кнопку OK или клавишу ENTER.

Псевдоним

Образец его использования

BmpDir=C:

$BmpDir\BITMAPS\PUMP.BMP

BmpDir=C:\

$(BmpDir)BITMAPS\PUMP.BMP

BmpDir=C:\BITMPAS

$BmpDir\PUMP.BMP

BmpDir=C:\BITMPAS\

$(BmpDir)PUMP.BMP

BmpDir=C:\BITMPAS\PUMP

$BmpDir.BMP

BmpDir=C:\BITMPAS\PUMP.BMP

$BmpDir

Создание вложенных псевдонимов пути

VisSim позволяет определять псевдонимы по правилам вложения (см. определение псевдонимов для первых четырех bmp-файлов на рисунке).

BMP_DISK=C:
BMP_PATH=$BMP_DISK\BITMAPS
FIG1=$BMP_PATH\fig1.bmp
FIG2=$BMP_PATH\fig2.bmp
FIG3=$BMP_PATH\fig3.bmp
FIG4=$BMP_PATH\fig4.bmp
FIG5=C:\BITMAPS\fig5.bmp
FIG6=C:\BITMAPS\fig6.bmp
FIG7=C:\BITMAPS\fig7.bmp
FIG8=C:\BITMAPS\fig8.bmp
...

Для уяснения ценности применения правила вложения. Сравните объем действий по редактированию псевдонимов первых четырех и всех последующих файлов при изменении имени каталога.

Информация о блок-схеме

Общую информацию о текущем рабочем файле Вы можете получить, вызвав команду меню Файл > Свойства. В появляющемся диалоговом окне Вы можете:

Обратите внимание, что название файла, для облегчения Вашего выбора, будет появляться в диалоговом окне добавления vsm-файла к проекту. А размер файла и информация о последней модификации обновляется только при сохранении рабочего файла.

Для получения информации о блок-схеме или внесения изменений выполните действия:

  1. Откройте блок-схему, информация о которой интересна Вам или должна быть модифицирована.
  2. Выберите команду меню Файл > Свойства.
  3. Изучите информацию о блок-схеме или модифицируйте ее.
  4. Нажмите на кнопку OK или клавишу ENTER.

Уровни защиты вашего проекта

VisSim имеет несколько уровней защиты вашего проекта:

Перечисленные меры в основном предназначены для исключения случайных модификаций при выполнении большого проекта группой исполнителей. Если применен уровень защиты "Только чтение", то симуляция возможна. Обратите внимание, что пароль может состоять не более чем из 10 символов латинского алфавита и чисел (чувствительность к регистру имеется). Примите меры к сохранению пароля в надежном месте. При его утрате доступ к vsm-файлу будет невозможен.

Защита блок-схем

Определить уровень ограничения доступа к вашей блок-схеме Вы можете, используя команду меню Файл > Свойства.

Диалоговое окно 'Информация о блок-схеме'

Уровень защиты

Активизация и описание

Защита vsm-файла от просмотра другими пользователями

Введите пароль в одноименной строке ввода и активизируйте опцию "Блокировка". В этом случае только те пользователи, которым будет сообщен пароль, смогут открыть блок-схему, модифицировать ее и снять пароль

Парольная защита vsm-файла от модификаций

Введите пароль в одноименной строке ввода и активизируйте опцию "Только чтение". В этом случае все пользователи могут ознакомиться с блок-схемой или использовать ее. Однако только те пользователи, которым будет сообщен пароль, смогут модифицировать ее и снять пароль

Беспарольная защита vsm-файла от модификаций

Активизируйте опцию "Только чтение" (пароль вводить не нужно). В этом случае все пользователи могут ознакомиться с блок-схемой или использовать ее. И все пользователи смогут модифицировать блок-схему, деактивировав опцию "Только чтение". Смысл этой защиты в том, чтобы исключить случайные модификации

Ограничение доступа к блок-схеме

Для ограничения доступа к блок-схеме (к vsm-файлу) выполните действия:

  1. Откройте vsm-файл, доступ к которому должен быть ограничен.
  2. Выберите команду меню Файл > Свойства.
  3. Ограничьте доступ, выполнив подходящую последовательность действий:
  4. Нажмите на кнопку OK или клавишу ENTER. Появится окно для проверки пароля.
  5. Повторно введите пароль.
  6. Нажмите на кнопку OK или клавишу ENTER.

Обратите внимание, что пароль может состоять не более чем из 10 символов латинского алфавита и чисел (чувствительность к регистру имеется). Примите меры к сохранению пароля в надежном месте. При его утрате доступ к vsm-файлу будет невозможен.

Изменение или удаление пароля доступа к блок-схеме

Для изменения или удаления пароля доступа к блок-схеме (к vsm-файлу) выполните действия:

  1. Выберите команду меню Файл > Свойства.
  2. Выполните подходящую последовательность действий для строки ввода пароля:
  3. Нажмите на кнопку OK или клавишу ENTER.

Если Вы ввели новый пароль, то появится окно проверки пароля.

Защита составных блоков

VisSim позволяет ограничить доступ к любому составному блоку. При этом имеется несколько уровней защиты:

Таким образом, уровни защиты составного блока подобны тем, которые применяются для блок-схемы в целом. Требуемый уровень защиты определяется в диалоговом окне "Свойства составного блока":

Диалоговое окно 'Свойства составного блока'

Ограничение доступа к составному блоку

Для ограничения доступа к составному блоку выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой составной блок, доступ к которому должен быть ограничен. Должно появиться диалоговое окно "Свойства составного блока".
  3. Ограничьте доступ, выполнив подходящую последовательность действий:
  4. Нажмите на кнопку OK или клавишу ENTER. Появится окно для проверки пароля.
  5. Повторно введите пароль.
  6. Нажмите на кнопку OK или клавишу ENTER.

Обратите внимание, что пароль может состоять не более чем из 10 символов латинского алфавита и чисел (чувствительность к регистру имеется). Примите меры к сохранению пароля в надежном месте. При его утрате доступ к составному блоку будет невозможен.

Изменение или удаление пароля доступа к составному блоку

Для изменения или удаления пароля доступа к составному блоку выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой требуемый составной блок. Должно появиться диалоговое окно "Свойства составного блока".
  3. Если в текущем сеансе работы Вы еще не имеете доступа к составному блоку, то в строке ввода "Пароль" удалите звездочки и введите его. Если пароль водится Вами правильно, то опции "Блокировка" и "Только чтение" активируются для модификаций.
  4. Выполните подходящую последовательность действий для строки ввода пароля:
  5. Нажмите на кнопку OK или клавишу ENTER. Должно появится контрольное диалоговое окно.
  6. Либо подтвердите вводом новый пароль, либо подтвердите операцию снятия пароля.
  7. Сохраните файл.

Редактирование составного блока защищенного от модификаций паролем

Для снятия парольной защиты с составного блока, которая предохраняет его от модификаций, те для деактивации режима "только чтение" выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой требуемый составной блок. Должно появиться диалоговое окно "Свойства составного блока".
  3. В строке ввода "Пароль" удалите звездочки и введите его. Если пароль водится Вами правильно, то опции "Блокировка" и "Только чтение" активируются для модификаций.
  4. Деактивируйте опцию "Только чтение".
  5. Нажмите на кнопку OK или клавишу ENTER.

Защита блоков внедрения

Механизм внедрения vsm-файлов предоставляет Вам наиболее удобную возможность распространения ваших унифицированных фрагментов блок-схем для построения более сложных проектов. Парольная защита (блокировка) составного блока, который будет внедряться другими пользователями в их модели, поможет Вам блюсти свои интересы. Только те пользователи, которым будет сообщен пароль, смогут перейти внутрь внедренного блока, изучить его построение, менять параметры и начальные условия, а, открыв исходный vsm-файл, смогут модифицировать структуру и снять пароль.

Итак, защита не устанавливается на блок внедрения непосредственно, а наследуется от исходного vsm-файла.

Обратите внимание, Вы можете ограничить доступ не только к составному блоку, но и к исходному файлу в целом. Тогда, только те пользователи, которым будет сообщен пароль к vsm-файлу, смогут внедрять его содержимое в свои модели. При этом Вы можете не сообщать пользователям пароль, защищающий сам составной блок.

Переход в защищенный блок внедрения

Для просмотра содержимого защищенного блока внедрения выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  2. Укажите мышкой требуемый блок внедрения. Должно появиться диалоговое окно "Внедрение файла в блок".
  3. В строке ввода "Пароль" введите пароль.
  4. Нажмите на кнопку OK или клавишу ENTER.
  5. Осуществите переход внутрь блока внедрения, щелкнув по нему другой клавишей мыши.

Строку ввода пароля можно вызвать иначе: позиционируйте курсор мыши над требуемым блоком внедрения и нажмите другую клавишу мыши. Не забывайте об альтернативной возможности вызова диалоговых окон свойств блоков посредствам другой клавиши мыши при удержании клавиши CTRL.

Защита внедряемой блок-схемы

В итоговом проекте, имеет смысл только один уровень защиты внедряемого из vsm-файла составного блока - это "Блокировка", поскольку модификация внедренных файлов в итоговом проекте запрещена. Однако защита от модификаций составного блока в исходном файле так же может представлять интерес.

Для ограничения доступа к блоку внедрения выполните действия:

  1. Откройте исходный vsm-файл, который содержит составной блок, предназначенный для внедрения в другие проекты.
  2. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  3. Укажите мышкой составной блок. Должно появиться диалоговое окно "Свойства составного блока".
  4. Ограничьте доступ, выполнив подходящую последовательность действий:
  5. Нажмите на кнопку OK или клавишу ENTER. Появится окно для проверки пароля.
  6. Повторно введите пароль.
  7. Нажмите на кнопку OK или клавишу ENTER.
  8. Сохраните файл, вернитесь к работе с итоговым проектом.

Обратите внимание, что пароль может состоять не более чем из 10 символов латинского алфавита и чисел (чувствительность к регистру имеется). Примите меры к сохранению пароля в надежном месте. При его утрате доступ к составному блоку будет невозможен.

Изменение или удаление пароля доступа к внедряемой блок-схеме

Для изменения или удаления пароля доступа к внедряемой блок-схеме выполните действия:

  1. Откройте исходный vsm-файл, который содержит составной блок, предназначенный для внедрения в другие проекты.
  2. Выберите команду меню Правка > Свойства блока (курсор мыши сменится на гаечный ключ).
  3. Укажите мышкой составной блок. Должно появиться диалоговое окно "Свойства составного блока".
  4. В строке ввода "Пароль" удалите звездочки и введите его. Если пароль водится Вами правильно, то опции "Блокировка" и "Только чтение" активируются для модификаций.
  5. Выполните подходящую последовательность действий для строки ввода пароля:
  6. Нажмите на кнопку OK или клавишу ENTER. Должно появится контрольное диалоговое окно.
  7. Либо подтвердите вводом новый пароль, либо подтвердите операцию снятия пароля.
  8. Сохраните файл, вернитесь к работе с итоговым проектом.