Визуализация результатов - координат модели

Осциллограф

Виртуальный запоминающий осциллограф в пакете VisSim является прибором двумерной визуализации информации. Основные технические параметры и режимы работы осциллографа следующие:

Основные режимы осциллографа

Если в вашей модели Вы установите блок осциллограф и подключите к его входам желаемые сигналы, то при выполнении симуляции они будут визуализироваться. В течение симуляции, все данные представляются во временном домене (обычно, X - ось времени, Y - ось значений функции), но если активирована опция "Спектр (БПФ)", то после завершения симуляции временная функция будет автоматически замещена ее спектром.

Демонстрация основных возможностей виртуального осциллографа

Рис. 1 (для замораживания анимации нажмите кнопку браузера "Остановить"; для повторного запуска анимации — щелкните указателем мыши по рисунку)

На рисунке демонстрируются основные возможности виртуального осциллографа:

Фазовые траектории (XY-график)

Режим осциллографа "Фазовая XY-плоскость" позволит Вам, используя один из входных сигналов, переопределить по умолчанию временную X-координату (X=t) функциональной зависимостью (X=F1(t)). Эта возможность особенно полезна при построении фазовых траекторий нелинейных систем регулирования.

Демонстрация на фазовой XY-плоскости процесса приближения к устойчивому предельному циклу координат системы с нелинейностью типа 'люфт'. Для повторного запуска щелкните мышкой

Рис. 2

Включение XY-графика

Для переключения разверток виртуального осциллографа в режим отображения фазовых траекторий (в режим XY-графика) выполните действия:

  1. Расположите указатель мыши над блоком осциллограф. Вид указателя должен смениться на перемещающие стрелки Данный вид указателя мыши сообщает о возможности перемещения или выделения блока.
  2. Нажмите другую кнопку мыши. Появится диалоговое окно настроек осциллографа.
  3. На вкладке "Опции" активизируйте опцию "Фазовая XY-плоскость".
  4. С помощью выпадающего списка "X-ось" назначьте номер входа, сигнал на котором будет определять X-координату. Номер входа увеличивается с верхнего.
  5. Нажмите на кнопку OK или клавишу ENTER.

Если Вам требуется отображать совокупность фазовых траекторий с разными X-координатами (до 4 шт.), то дополнительно активируйте опцию "Множество XY-плоскостей".

Назначение метки для X-оси XY-графика

В режиме осциллографа "Фазовая XY-плоскость" VisSim автоматически подписывает ось X  той меткой, которая назначена соответствующему входному сигналу (см. кадры 11 и 12 на рис. 1), а не указываемой в строке ввода "X Метка". Например, если Вы активизируете опцию "Фазовая XY-плоскость" и выбираете второй канал для генерации X-координаты, VisSim будет использовать метку назначенную сигналу второго канала для подписи оси X.

Для оформления текстовой подписи для оси Х виртуального осциллографа в режиме отображения фазовых траекторий (в режиме XY-графика) выполните действия:

  1. Расположите указатель мыши над блоком осциллограф. Вид указателя должен смениться на перемещающие стрелки Данный вид указателя мыши сообщает о возможности перемещения или выделения блока.
  2. Нажмите другую кнопку мыши. Появится диалоговое окно настроек осциллографа.
  3. На вкладке "Опции" взглянув на выпадающий список "X-ось" уточните номер канала, который используется для развертки по горизонтальной оси.
  4. На вкладке "Метки" введите текст в соответствующей строке ввода ("Канал 1", или 2, ... 4).
  5. Нажмите на кнопку OK или клавишу ENTER.

Размер окна осциллографа

Блок виртуального осциллографа отображается окном, которое имеет стандартные средства управления размерами. Используя кнопки в правой верхней его части, Вы можете увеличить дисплей осциллографа до полноэкранного размера или удалить его. Если требуется изменить размер дисплея, то Вам следует подвести указатель мыши к границе окна (или к его углам), и после смены вида курсора мыши на перемещающие стрелки выполнить коррекцию размера.

Масштабирование

Для детального ознакомления с фрагментом осциллограммы имеется возможность увеличить любую требуемую область дисплея. Регистрируемые виртуальным осциллографом данные имеют большую точность (тип double), поэтому в отличие от реальных приборов сильное увеличение может не терять смысл. Но если выделенная область не содержит ни одной точки данных, то дисплей будет пуст. Приблизить изображение можно в несколько приемов, а сбросить осциллограмму к исходному масштабу можно только за один шаг. Попытки сделать масштаб по оси времени более мелким, чем исходный, будут игнорироваться, поскольку невозможно показать осциллограмму для блок-схемы на временном периоде, большем, чем заданное время симуляции. Измените время симуляции - поменяется исходный временной масштаб осциллограммы.

Для детального ознакомления с фрагментом осциллограммы (для увеличения масштаба) выполните действия:

  1. Нажмите и удерживайте клавишу CTRL.
  2. С помощью указателя мыши выделите требуемую область осциллограммы (нажав кнопку мыши и переместив указатель по диагонали). При этом в процессе перемещения указателя его текущие координаты в осциллограмме будут подсвечиваться цветом морской волны, в левой нижней части окна осциллографа.
  3. Отпустите кнопку мыши - будет выполнено масштабирование.
  4. Если требуется дополнительное увеличение, то повторите шаги 2 и 3.
  5. Отпустите клавишу CTRL.

Для сброса осциллограммы к исходному масштабу выполните действия:

  1. Нажмите и удерживайте клавишу CTRL.
  2. Расположите указатель мыши над дисплеем виртуального осциллографа.
  3. Щелкните другой кнопкой мыши. Масштаб будет сброшен к исходному.
  4. Отпустите клавишу CTRL.

Распечатка осциллограммы

Для распечатки осциллограммы выберите команду "Print" в системном меню окна осциллографа (верхний левый угол окна).

Вкладка 'Опции' осциллографа

Вкладка "Опции" диалогового окна "Настройки запоминающего осциллографа" позволяет осуществлять наиболее эффективные операции и управлять наиболее важными режимами работы прибора.

Порядок обращения к вкладке "Опции" диалогового окна "Настройки запоминающего осциллографа":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну осциллографа и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки запоминающего осциллографа" выберите вкладку "Опции".
  4. Выполните коррекцию необходимых опций или осуществите желаемые действия.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки запоминающего осциллографа'. Вкладка 'Опции'

Гораздо быстрее вызвать диалоговое окно "Настройки запоминающего осциллографа" можно посредствам мыши, расположив указатель над окном осциллографа и щелкнув другой кнопкой мыши. Описание опций приведено в таблице.

Опция

Описание

Фиксация диапазонов

Опция позволяет отключить режим автомасштабирования У-оси и определить границы интересующего фрагмента осциллограммы для просмотра. Если опция активна, то VisSim использует для визуализации те пределы, которые будут Вами указаны на вкладке "Оси"

Спектр (БПФ)

Опция активизирует процесс выполнения операции быстрого преобразования Фурье (БПФ) для тех данных временного домена (для осциллограммы сигнала), которые остаются на дисплее после завершения процесса симуляции модели. Результат возвращается в виде плотности спектра мощности сигнала.

Точностные показатели результата жестко связаны с количеством зарегистрированных точек виртуальным осциллографом. Их количество должно быть кратно степеням двойки (8, 16, 32, 64, 128, ...) иначе спектр будет зашумлен. Имеется несколько влияющих факторов: 1) Опция "БПФ по 2^n точкам" будет обрезать последовательность выборок до соответствующего ближайшего количества. 2) Установка времени симуляции и шага для накопления требуемого количества точек может оказаться лучшим решением. 3) Опция "Max количество точек" может ограничить точность результата, но, как и внешняя синхронизация, может повысить скорость расчетов. 4) Если Вы остановите процесс симуляции преждевременно, то точность выполнения операции уменьшится

БПФ по 2^n точкам

Опция "БПФ по 2^n точкам" обрезает последовательность накопленных выборок до ближайшей степени двойки при выполнении быстрого преобразования Фурье. Если опция не активна, то последовательность данных дополняется нулями до количества кратного ближайшей степени двойки.

Эта опция может быть активирована только, когда активна опция "Спектр (БПФ)"

Запоминание следов

Активизация опции приводит к сохранению указанного количества последних следов осциллограмм при повторных симуляциях. Это дает возможность отследить действие вариации параметров на модель. В строке ввода "Кол-во:" Вам необходимо ввести число хранимых следов

Кол-во:

Определяет количество хранимых следов осциллограмм в режиме "Запоминание следов"

Очистить график

Команда приводит к очистке всех следов осциллограмм.

Маркеры

Опция позволяет оформить регистрируемые данные геометрическими маркерами. Вид маркера можно уточнить на вкладке "Лучи". Подобное оформление полезно для распечаток на черно-белом принтере и при визуализации на монохромном дисплее

Их кол-во:

Определяет количество маркеров на лучах осциллограмм. Если указано число 0 (ноль), то маркером будет оформляться каждая выборка

Внешняя синхронизация

Активизация опции приводит к появлению у осциллографа дополнительного входа круглой формы, с помощью которого может быть организована внешняя синхронизация логическим сигналом - 0 или 1. Стробирование данных (регистрация и вывод на дисплей) осуществляется, если сигнал синхронизации равен единице (1).

Фазовая XY-плоскость

Опция активизирует режим разверток осциллографа для визуализации данных на фазовой плоскости. В отличие от обычного режима один из входных сигналов будет управлять горизонтальной разверткой. Для дополнительной информации см. раздел: Фазовые траектории (XY-график)

Множество XY-плоскостей

Активизация опции позволяет задействовать до четырех независимых фазовых разверток осциллографа. Если же опция не активна, то развертка по горизонтальному каналу будет осуществляться одним входным сигналом для семи каналов вертикального отклонения

Тип следа

Тип следа "линия" используется наиболее часто, поскольку позволяет визуально скрыть дискретную природу любой компьютерной модели и представить осциллограмму в виде, который максимально подходит непрерывным системам. В черно-белом режиме лучи каналов отображаются штрих-пунктирными линиями разной длинны, но необходимо, что бы между точками было достаточное расстояние, иначе возникнет перекрытие штришков. В этом случае рекомендуется пользоватся маркерами.

Тип следа "точки" позволяет визуализировать данные индивидуально, в виде решетчатой функции, что максимально соответствует математическому описанию цифровых систем. Подобный след удобен, если предполагается прецизионно ("с привязкой") снимать данные с осциллограммы.

Тип следа "ступени" удобен при регистрации нерегулярных данных, позволяя отследить участки осциллограмм с малым количеством выборок. Подобный тип осциллограммы максимально соответствует природе цифро-аналоговых устройств и устройств выборки-хранения

Max кол-во точек:

Максимальное число регистрируемых и отображаемых на экране выборок может составлять 250 миллионов. Выборки могут регистрироваться столь плотно, что соседние при визуализации будут попадать в один пиксель экрана. В подобных случаях Вы можете вести регистрацию с прореживанием. Тогда все операции перерисовки и печати осциллограммы будут существенно ускорены. В большинстве случаев достаточно 100 точек, если не требуется последующее изучение данных с увеличением масштаба. Если в строке ввода ввести цифру ноль (0), то режим прореживания будет отключен.

Если Вы можете предсказать каким количеством точек ваши данные могут быть качественно визуализированы, то, возможно, Вам стоит задать "максимальное число точек в следах лучей дисплеев" в диалоговом окне "Настройки симуляции" на вкладке "Предустановки".

Точек на экране:

Это затемненное поле отображает количество выборок, которые составили осциллограмму

Log X & Log Y

Обе опции действуют независимо друг от друга и предназначены для переключения между линейным и логарифмическим масштабами представления данных. Активизация опции соответствует включению логарифмического масштаба по соответствующей оси. Однако в этом случае невозможно отобразить отрицательные данные. При их появлении в исходной совокупности выборок произойдет отсечение графика в декаде, в которую попадет наименьшее положительное значение

Y - в [дБ]

Активизация опции приводит к оформлению меток значений по оси Y в децибелах (20Lg(Y)). Если значение в логарифмическом масштабе изменилось на 20дБ, то в линейном масштабе это соответствует изменению в 10 раз. Опция оказывает влияние на вид сетки логарифмического масштаба (при ее включении).

Сетка

Активизация опции включает координатную сетку. Интервал между линиями сетки устанавливается автоматически, в зависимости от диапазонов визуализации и размера графика. Но, возможно определить сетку принудительно, на вкладке "Оси"

Снятие координат

Этот инструментарий позволяет с высокой точностью (см. опцию "с привязкой") исследовать значения зарегистрированных координат. При нажатии на кнопку на дисплее осциллографа появляется зеленое перекрестие, позиционируемое как мышкой, так и стрелками клавиатуры. При движении перекрестия его текущие координаты подсвечиваются в нижней части дисплея в прямоугольнике цвета морской волны. Если Вы нажмете кнопку мыши или клавишу ENTER, то перекрестие зафиксируется. Повторное нажатие левой кнопки мыши приводит к обновлению дисплея и стиранию перекрестия

с привязкой

Активизация опции позволяет повысить точность снятия координат выше графического разрешения дисплея осциллографа. В этом режиме перекрестие программно притягивается к ближайшей точке на дисплее и по ее графическим координатам уточняется и подсвечивается реальное зарегистрированное значение

X-Xo Y-Yo

Опция позволяет оставить прежнее перекрестие и воспользоваться новым для определения разницы между координатами двух точек. Если координаты первой точки Вас не удовлетворяют, то вновь воспользуйтесь командой снятия координат при активном состоянии этой опции

График - в файл

Нажатие на эту кнопку вызывает открытие файлового диалогового окна с возможностью уточнения имени и типа файла для записи зарегистрированных осциллографом данных. Раскройте в диалоговом окне выпадающий список "Тип файлов" для выбора требуемого формата сохранения

Вкладка 'Метки' осциллографа

Вкладка "Метки" диалогового окна "Настройки запоминающего осциллографа" позволяет должным образом оформить текстовые надписи на дисплее. В частности, подписать оси, дать имя семейству осциллограмм и определить название каждой.

Порядок обращения к вкладке "Метки" диалогового окна "Настройки запоминающего осциллографа":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну осциллографа и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки запоминающего осциллографа" выберите вкладку "Метки".
  4. Отредактируйте или введите требуемый текст в строках ввода.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки запоминающего осциллографа'. Вкладка 'Метки'

Название строки ввода

Описание

Заголовок & Подзаголовок

Заголовок позволяет определить название визуализирующего дисплея. Подзаголовок - название семейства осциллограмм. Обе строки ввода позволяют ввести до 80 алфавитно-цифровых символов. Заголовок появляется в строке названия окна осциллографа. Подзаголовок отображается в верхней области дисплея

X Метка & Y Метка

В строках ввода "X Метка" и "Y Метка" можно определить подписи для соответствующих осей. Обе строки ввода позволяют ввести до 80 алфавитно-цифровых символов. Об оформлении текстовой подписи для оси Х осциллографа в режиме отображения фазовых траекторий (в режиме XY-графика) см. раздел: Назначение метки для X-оси XY-графика

Канал 1, Канал 2, ..., Канал 8

Используя эти строки ввода, Вы можете указать названия осциллограмм, которые регистрируются соответствующими каналами прибора. Верхний вход - это вход первого канала. Каждая строка ввода позволяет ввести до 80 алфавитно-цифровых символов

Вкладка 'Оси' осциллографа

Вкладка "Оси" диалогового окна "Настройки запоминающего осциллографа" позволяет вручную определить диапазоны визуализируемой дисплеем области и параметры сетки, настроить обратный ход развертки и выбрать единицу времени для подписи оси X.

Порядок обращения к вкладке "Оси" диалогового окна "Настройки запоминающего осциллографа":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну осциллографа и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки запоминающего осциллографа" выберите вкладку "Оси".
  4. Определите пределы или выполните коррекцию необходимых опций.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки запоминающего осциллографа'. Вкладка 'Оси'

Опция

Описание

Y Верхний предел, Y Нижний предел; X Верхний предел, X Нижний предел

В этих строках ввода вы можете вручную задать численные значения границ отображаемой дисплеем осциллографа области. Эти границы будут действительны в случае, если Вы активизируете на вкладке "Опции" параметр "Фиксация диапазонов"

Единицы времени

Используя этот выпадающий список, можно назначить требуемую единицу измерения времени от микросекунд до годов. При изменении установленных ранее единиц производится коррекция подписей числовых значений на шкале дисплея, и масштабируются значения в полях ввода X-пределов. Если Вами будет осуществлен оптимальный выбор единиц, то подписи будут требовать наименьшее количество знакомест, которые будут заняты ненулевыми цифрами мантиссы, а автомасштабирующаяся сетка будет наиболее плотной

Сетка

Активизация опции "Фиксировать" позволит Вам отключить режим автомасштабирования сетки и ввести в поля ввода с именами "X делений" и "Y делений" количество отрезков, на которые сетка поделит соответствующие оси. Если в каком-то из названных полей ввода Вы введете цифру ноль, то по соответствующей оси режим автомасштабирования сетки не будет отключен

Повтор развертки

Активизация опции "Обратный ход" позволит Вам включить классический для осциллографов режим работы, при котором луч прибора пробегая дисплей, быстро возвращается в его начало (не оставляя при обратном ходе следа) и вновь, с течением времени, движется по дисплею. Поля ввода "С времени" и "До времени" определяют отрезок во временном диапазоне процесса симуляции, когда осциллограф будет регистрировать данные. Поле ввода "На интервале" позволит Вам определить временной период продвижения луча по дисплею

Вкладка 'Оформление' осциллографа

Вкладка "Оформление" диалогового окна "Настройки запоминающего осциллографа" позволяет определить цветовое оформление дисплея и подключить фоновое изображение для осциллограмм. Фоновое изображение может являться спец-сеткой, например, линиями уровня показателя колебательности M для диаграммы Найквиста - АФХ (частотные характеристики в VisSim-е так же визуализируются с помощью виртуального осциллографа).

Порядок обращения к вкладке "Оформление" диалогового окна "Настройки запоминающего осциллографа":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну осциллографа и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки запоминающего осциллографа" выберите вкладку "Оформление".
  4. Определите цветовое оформление или введите имя файла фонового изображения.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки запоминающего осциллографа'. Вкладка 'Оформление'

Опция

Описание

Цвет

Активизация опции "Перекрыть цвет" позволяет выполнить одноименную операцию с помощью кнопок "Элементы" и "Фон" для рамки, числовых и текстовых подписей на осях и фона дисплея. При этом перекрываются те цвета, которые назначены по умолчанию посредствам команды меню Вид > Цвет

Растровое изображение - спец-сетка

Кнопка "Изображение" выведет диалоговое окно, для облегчения ввода пути к файлу с фоновым изображением, подключение которого отменит действие цветового оформления фона. Допустимо использование только bmp-файлов растровой графики

Вкладка 'Лучи' осциллографа

Вкладка "Лучи" диалогового окна "Настройки запоминающего осциллографа" позволяет определить цветовое оформление осциллограмм и назначить тип маркеров идентифицирующих осциллограммы на черно-белых визуализирующих устройствах.

Порядок обращения к вкладке "Лучи" диалогового окна "Настройки запоминающего осциллографа":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну осциллографа и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки запоминающего осциллографа" выберите вкладку "Лучи".
  4. В выпадающих списках осуществите выбор цветового оформления лучей и тип маркеров для соответствующих каналов.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки запоминающего осциллографа'. Вкладка 'Лучи'

Самописец

Блок виртуального прибора с именем самописец позволяет регистрировать по восьми каналам входные сигналы долго протекающих процессов во временном окне с прокруткой. Вы можете определить ширину временного окна отображаемого дисплеем и интервал хранения истории. Для изучения исторических данных следует использовать горизонтальную полосу прокрутки, прикрепленную к нижней части окна блока самописец.

Основные технические параметры и режимы работы блока самописец следующие:

Основной режим самописца

Подобно блоку осциллограф, блок самописец в любом режиме первоначально отображает данные во временном домене. Значения входных сигналов управляют вертикальной разверткой лучей, а горизонтальная развертка управляется временным сигналом. По мере увеличения двойной амплитуды входных сигналов самописец динамически масштабирует диапазон области отображения, корректируя оформление Y-оси.

Размер окна самописца

Блок виртуального самописца отображается окном, которое имеет стандартные средства управления размерами. Используя кнопки в правой верхней его части, Вы можете увеличить дисплей самописца до полноэкранного размера или удалить его. Если требуется изменить размер дисплея, то Вам следует подвести указатель мыши к границе окна (или к его углам), и после смены вида курсора мыши на перемещающие стрелки выполнить коррекцию размера.

Распечатка исторических данных

Для распечатки исторических данных самописца выберите команду "Print" в системном меню окна самописца (верхний левый угол окна). Печать будет выполняться в виде горизонтальных полос (до четырех штук на странице). Страниц при печати потребуется столько, сколько необходимо для печати установленного исторического интервала. Вы можете настроить размер полей при печати, используя команду меню Файл > Параметры страницы

Вкладка 'Опции' самописца

Вкладка "Опции" диалогового окна "Настройки самописца" позволяет осуществлять наиболее эффективные операции и управлять наиболее важными режимами работы прибора.

Порядок обращения к вкладке "Опции" диалогового окна "Настройки самописца":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну самописца и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки самописца" выберите вкладку "Опции".
  4. Выполните коррекцию необходимых опций или осуществите желаемые действия.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки самописца'. Вкладка 'Опции'

Гораздо быстрее вызвать диалоговое окно "Настройки самописца" можно посредствам мыши, расположив указатель над окном самописца и щелкнув другой кнопкой мыши. Описание "Опций" приведено в таблице.

Опция

Описание

Фиксация диапазонов

Опция позволяет отключить режим автомасштабирования У-оси и определить границы интересующего фрагмента осциллограммы для просмотра. Если опция активна, то VisSim использует для визуализации те пределы, которые будут Вами указаны на вкладке "Оси"

Спектр (БПФ)

Опция активизирует процесс выполнения операции быстрого преобразования Фурье (БПФ) для тех данных временного домена (для осциллограммы сигнала), которые остаются на дисплее после завершения процесса симуляции модели. Результат возвращается в виде плотности спектра мощности сигнала.

Точностные показатели результата жестко связаны с количеством зарегистрированных точек виртуальным самописцем. Их количество должно быть кратно степеням двойки (128, 256, 512, 1024, 2048, ...) иначе спектр будет зашумлен. Имеется несколько влияющих факторов: 1) Установка времени симуляции и шага для накопления требуемого количества точек может оказаться лучшим решением. 2) Опция "Max количество точек" может ограничить точность результата, но, как и внешняя синхронизация, может повысить скорость расчетов. 3) Если Вы остановите процесс симуляции преждевременно, то точность выполнения операции уменьшится

Маркеры

Опция позволяет оформить регистрируемые данные геометрическими маркерами. Вид маркера можно уточнить на вкладке "Лучи". Подобное оформление полезно для распечаток на черно-белом принтере и при визуализации на монохромном дисплее

Их кол-во:

Определяет количество маркеров на лучах осциллограмм. Если указано число 0 или -1, то маркером будет оформляться каждая выборка

Внешняя синхронизация

Активизация опции приводит к появлению у самописца дополнительного входа круглой формы, с помощью которого может быть организована внешняя синхронизация логическим сигналом - 0 или 1. Стробирование данных (регистрация и вывод на дисплей) осуществляется, если сигнал синхронизации равен единице (1).

Тип следа

Тип следа "линия" используется наиболее часто, поскольку позволяет визуально скрыть дискретную природу любой компьютерной модели и представить осциллограмму в виде, который максимально подходит непрерывным системам. В черно-белом режиме лучи каналов отображаются штрих-пунктирными линиями разной длинны, но необходимо, что бы между точками было достаточное расстояние, иначе возникнет перекрытие штришков. В этом случае рекомендуется пользоватся маркерами.

Тип следа "точки" позволяет визуализировать данные индивидуально, в виде решетчатой функции, что максимально соответствует математическому описанию цифровых систем. Подобный след удобен, если предполагается прецизионно ("с привязкой") снимать данные с осциллограммы.

Тип следа "ступени" удобен при регистрации нерегулярных данных, позволяя отследить участки осциллограмм с малым количеством выборок. Подобный тип осциллограммы максимально соответствует природе цифро-аналоговых устройств и устройств выборки-хранения

Max кол-во точек:

Эта опция для самописца не столь актуальна, как для осциллографа, но может потребоваться в некоторых случаях.

Максимальное число регистрируемых и отображаемых на экране выборок может составлять 250 миллионов (зависит от операционной системы). Выборки могут регистрироваться столь плотно, что соседние при визуализации будут попадать в один пиксель экрана. В подобных случаях Вы можете вести регистрацию с прореживанием. Тогда все операции перерисовки и печати осциллограммы будут существенно ускорены. В большинстве случаев достаточно 100 точек, если не требуется последующее изучение данных с увеличением масштаба. Если в строке ввода ввести цифру ноль (0), то режим прореживания будет отключен.

Если Вы можете предсказать каким количеством точек ваши данные могут быть качественно визуализированы, то, возможно, Вам стоит задать "максимальное число точек в следах лучей дисплеев" в диалоговом окне "Настройки симуляции" на вкладке "Предустановки".

LogY

Опция предназначена для переключения между линейным и логарифмическим масштабами представления данных по оси Y. Однако, при активизации логарифмического масштаба невозможно отобразить отрицательные данные. При их появлении в исходной совокупности выборок произойдет отсечение графика в декаде, в которую попадет наименьшее положительное значение

Y - в [дБ]

Активизация опции приводит к оформлению меток значений по оси Y в децибелах (20Lg(Y)). Если значение в логарифмическом масштабе изменилось на 20дБ, то в линейном масштабе это соответствует изменению в 10 раз. Опция оказывает влияние на вид сетки логарифмического масштаба (при ее включении).

Сетка

Активизация опции включает координатную сетку. Интервал между линиями сетки устанавливается автоматически, в зависимости от диапазонов визуализации и размера графика. Но, возможно определить сетку принудительно, на вкладке "Оси"

Снятие координат

Этот инструментарий позволяет исследовать значения зарегистрированных координат. При нажатии на кнопку, на дисплее самописца появляется зеленое перекрестие позиционируемое как мышкой, так и стрелками клавиатуры. При движении перекрестия его текущие координаты подсвечиваются в нижней части дисплея в прямоугольнике цвета морской волны. Если Вы нажмете кнопку мыши или клавишу ENTER, то перекрестие зафиксируется. Повторное нажатие левой кнопки мыши приводит к обновлению дисплея и стиранию перекрестия

X-Xo Y-Yo

Опция позволяет оставить прежнее перекрестие и воспользоваться новым для определения разницы между координатами двух точек. Если координаты первой точки Вас не удовлетворяют, то вновь воспользуйтесь командой снятия координат при активном состоянии этой опции

График - в файл

Нажатие на эту кнопку вызывает открытие файлового диалогового окна с возможностью уточнения имени и типа файла для записи зарегистрированных самописцем данных. Раскройте в диалоговом окне выпадающий список "Тип файлов" для выбора требуемого формата сохранения

Вкладка 'Метки' самописца

Вкладка "Метки" диалогового окна "Настройки самописца" позволяет должным образом оформить текстовые надписи на дисплее. В частности, подписать оси, дать имя семейству осциллограмм и определить название каждой.

Порядок обращения к вкладке "Метки" диалогового окна "Настройки самописца":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну самописца и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки самописца" выберите вкладку "Метки".
  4. Отредактируйте или введите требуемый текст в строках ввода.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки самописца'. Вкладка 'Метки'

Название строки ввода

Описание

Заголовок & Подзаголовок

Заголовок позволяет определить название визуализирующего дисплея. Подзаголовок - название семейства осциллограмм. Обе строки ввода позволяют ввести до 80 алфавитно-цифровых символов. Заголовок появляется в строке названия окна самописца. Подзаголовок отображается в верхней области дисплея

X Метка & Y Метка

В строках ввода "X Метка" и "Y Метка" можно определить подписи для соответствующих осей. Обе строки ввода позволяют ввести до 80 алфавитно-цифровых символов

Канал 1, Канал 2, ..., Канал 8

Используя эти строки ввода, Вы можете указать названия осциллограмм, которые регистрируются соответствующими каналами прибора. Верхний вход - это вход первого канала. Каждая строка ввода позволяет ввести до 80 алфавитно-цифровых символов

Вкладка 'Оси' самописца

Вкладка "Оси" диалогового окна "Настройки самописца" позволяет вручную определить диапазоны визуализируемой дисплеем области, параметры сетки и выбрать единицу времени для подписи оси X.

Порядок обращения к вкладке "Оси" диалогового окна "Настройки самописца":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну самописца и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки самописца" выберите вкладку "Оси".
  4. Определите пределы или выполните коррекцию необходимых опций.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки самописца'. Вкладка 'Оси'

Опция

Описание

Y Верхний предел, Y Нижний предел

В этих строках ввода вы можете вручную задать численные значения границ отображаемой дисплеем осциллографа области по оси Y. Эти границы будут действительны в случае, если Вы активизируете на вкладке "Опции" параметр "Фиксация диапазонов"

Временное окно

Введенное в этой строке ввода число, определит длину визуализируемого временного отрезка на дисплее самописца. По умолчанию величина окна составляет 1/4 от полного времени симуляции

Интервал истории

Введенное в этой строке ввода число, определит длину временного отрезка хранения исторических данных, которые становятся таковыми после выхода за пределы текущего временного окна самописца. По умолчанию интервал истории составляет 3/4 от полного времени симуляции. Вам необходимо помнить, что больший интервал истории требует для хранения большего количества памяти

Единицы времени

Используя этот выпадающий список, можно назначить требуемую единицу измерения времени от микросекунд до годов. При изменении установленных ранее единиц производится коррекция подписей числовых значений на шкале дисплея, и масштабируются значения в полях ввода X-пределов. Если Вами будет осуществлен оптимальный выбор единиц, то подписи будут требовать наименьшее количество знакомест, которые будут заняты ненулевыми цифрами мантиссы, а автомасштабирующаяся сетка будет наиболее плотной

Сетка

Активизация опции "Фиксировать" позволит Вам отключить режим автомасштабирования сетки и ввести в поля ввода с именами "X делений" и "Y делений" количество отрезков, на которые сетка поделит соответствующие оси. Если в каком-то из названных полей ввода Вы введете цифру ноль, то по соответствующей оси режим автомасштабирования сетки не будет отключен

Вкладка 'Оформление' самописца

Вкладка "Оформление" диалогового окна "Настройки самописца" позволяет определить цветовое оформление дисплея.

Порядок обращения к вкладке "Оформление" диалогового окна "Настройки самописца":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну самописца и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки самописца" выберите вкладку "Оформление".
  4. Определите цветовое оформление.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки самописца'. Вкладка 'Оформление'

Опция

Описание

Цвет

Активизация опции "Перекрыть цвет" позволяет выполнить одноименную операцию с помощью кнопок "Элементы" и "Фон" для рамки, числовых и текстовых подписей на осях и фона дисплея. При этом перекрываются те цвета, которые назначены по умолчанию посредствам команды меню Вид > Цвет

Вкладка 'Лучи' самописца

Вкладка "Лучи" диалогового окна "Настройки самописца" позволяет определить цветовое оформление осциллограмм и назначить тип маркеров идентифицирующих осциллограммы на черно-белых визуализирующих устройствах.

Порядок обращения к вкладке "Лучи" диалогового окна "Настройки самописца":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну самописца и нажмите кнопку мыши.
  3. В диалоговом окне "Настройки самописца" выберите вкладку "Лучи".
  4. В выпадающих списках осуществите выбор цветового оформления лучей и тип маркеров для соответствующих каналов.
  5. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки самописца'. Вкладка 'Лучи'

Гистограмма

Блок виртуального прибора гистограмма позволяет визуализировать вероятностное распределение величины в течение симуляции. Горизонтальная ось дисплея гистограммы разбита на "лотки" (интервалы). По вертикальной оси дисплея гистограммы можно определить какое количество раз случайная величина попала в конкретный "лоток". "Лотки" (интервалы) имеют равную длину и распределяются без разрывов между минимальным и максимальным значениями. Вы определяете количество интервалов, диапазон для значений случайной величины и максимальное значение на шкале вероятности (если Вас не удовлетворяет режим автомасштабирования).

Блок 'Гистограмма'

Размер окна гистограммы

Блок виртуального прибора гистограмма отображается окном, которое имеет стандартные средства управления размерами. Используя кнопки в правой верхней его части, Вы можете увеличить дисплей гистограммы до полноэкранного размера или удалить его. Если требуется изменить размер дисплея, то Вам следует подвести указатель мыши к границе окна (или к его углам), и после смены вида курсора мыши на перемещающие стрелки выполнить коррекцию размера.

Изменение опций гистограммы

Диалоговое окно "Настройки гистограммы" позволяет вносить коррекцию в оформление дисплея и осуществлять настройку прибора.

Порядок обращения к диалоговому окну "Настройки гистограммы":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну гистограммы и нажмите кнопку мыши.
  3. Выполните коррекцию необходимых опций.
  4. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройки гистограммы'

Гораздо быстрее вызвать диалоговое окно "Настройки гистограммы" можно посредствам мыши, расположив указатель над окном гистограммы и щелкнув другой кнопкой мыши. Описание опций приведено в таблице.

Опция

Описание

Название

В этой строке ввода Вы можете определить название гистограммы (до 80 алфавитно-цифровых символов). Название появляется в системной строке управления окном гистограммы

Метка ординаты & Метка абсциссы

В этих строках ввода можно определить подписи для соответствующих осей (до 80 алфавитно-цифровых символов)

Число интервалов

Введенное в этой строке ввода число определит количество "лотков" (интервалов) для подсчета выпадений случайной величины в каждый. Они будут иметь равную длину и будут распределены без разрывов между минимальным и максимальным значениями. Значение по умолчанию 10. Если Вы измените значение, то зарегистрированные в процессе симуляции данные будут сброшены

Max(Xi) & Min(Xi)

В этих строках ввода можно определить диапазон регистрации, в котором ожидаются значения случайной величины. Значения по умолчанию 1 и 0 соответственно

Высота

Эта строка ввода позволяет ограничить максимальное значение для вертикальной оси вероятности. Значение по умолчанию 10

Автомасштабирование высоты

Активация опции приводит к автомасштабированию вертикальной оси вероятности в случае, если количество выпадений в любой из интервалов превысит установленную величину в строке ввода "Высота"

Поджать данные в диапазон

Активация опции приводит к расширению диапазонов двух крайних лотков до +/- бесконечности. Это позволяет наглядно увидеть количество грубых ошибок, которые не подчиняются гипотезе о характере распределения (см. например: ГОСТ 11.002-73; ГОСТ 2.207-76)

Прибор

Блок прибор является стрелочным или шкальным указателем для визуализации постоянных или медленно меняющихся величин. Первоначально при установке в блок-схему он отображается в виде стрелочного указателя с одним входом. Однако, добавляя входы можно получить приборную панель, содержащую до четырех указателей. Добавить или удалить входы у блока прибор можно в соответствии с обычной методикой, воспользовавшись необходимой из кнопкой Кнопка добавления входа или выхода блоку Кнопка удаления входа или выхода у блока в инструментальной панели "Главная", или выбрав команду меню Правка > Добавить вывод / Удалить вывод.

Демонстрация стрелочных и шкальных визуализирующих приборов

Размер окна прибора

Блок прибор отображается окном, которое имеет стандартные средства управления размерами. Используя кнопки в правой верхней его части, Вы можете увеличить приборную панель до полноэкранного размера или удалить ее. Если требуется изменить размер панели, то Вам следует подвести указатель мыши к границе окна (или к его углам), и после смены вида курсора мыши на перемещающие стрелки выполнить коррекцию размера.

Изменение опций прибора

Диалоговое окно "Настройка панели приборов" позволяет определить тип дисплея (стрелочный или шкальный) внести коррекцию в текстовое и в цветовое оформление, а так же настроить шкалу.

Порядок обращения к диалоговому окну "Настройка панели приборов":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к окну блока прибор и нажмите кнопку мыши.
  3. Выполните коррекцию оформления панели приборов и настройте шкалу или шкалы.
  4. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Настройка панели приборов'

Гораздо быстрее вызвать диалоговое окно "Настройка панели приборов" можно посредствам мыши, расположив указатель над окном блока прибор и щелкнув другой кнопкой мыши. Описание опций приведено в таблице.

Опция

Описание

Стиль

Переключатель позволяет выбрать требуемый тип дисплея прибора - либо стрелочный, либо шкальный

Прибор #

Переключатель позволяет оформить и настроить шкалу каждого из четырех возможных приборов на панели. Цветовое оформление и "Оформление шкал" определяются индивидуально для каждого прибора в после выбора его номера

Заголовок окна

В этой строке ввода Вы можете определить название приборной панели (до 80 алфавитно-цифровых символов). Название появляется в системной строке управления окном приборной панели

Метка шкалы

В этой строке ввода Вы можете определить название шкалы каждого из приборов на панели (до 80 алфавитно-цифровых символов). Если прибор стрелочный, то название будет отображено горизонтально под осью стрелки. Если прибор шкальный, то - вертикально по левой стороне шкалы

Верхний предел & Нижний предел

В этих строках ввода можно определить диапазон регистрации входной величины. Значения по умолчанию 1 и 0 соответственно

Кол-во делений

Активизация опции требует введения количества отрезков, на которые будет поделена шкала прибора

Цвет... (Оформление)

Нажатие на эту кнопку вызывает открытие диалогового окна "Оформление". С его помощью Вы можете либо определить цвет шкал и фона для всех приборов панели, либо подключить фоновое изображение

Цветовая метка ...

Нажатие на эту кнопку вызывает открытие системного диалогового окна "Цвет". С его помощью Вы можете выбрать цвет раскраски области подвески у стрелочных приборов и полос у шкальных

Создание анимации

Анимация в программе VisSim - это ряд изображений, используя которые посредствам переключения или изменения их координат в течение процесса симуляции можно создать иллюзию движения. Библиотека VisSim-а имеет два анимационных блока: блок анимация - для покадрового переключения bmp-изображений и блок анимацияЛинии - для анимации отрезка линии методом пошагового изменения координат его начала и конца.

Анимация - обзор

Анимацию в VisSim-е можно наблюдать только в том случае, если активирован режим "Дисплей оператора" (см. меню Вид). В этом режиме (он оказывает действие только на текущий уровень блок-схемы) видима только та часть блоков, которые могут быть использованы для оформления "Дисплея оператора". Провода и (по указанию) составные блоки скрываются. Нельзя так же редактировать блок-схему, перемещать блоки, менять параметры. Но остается возможность вносить коррекцию в процесс симуляции модели посредствам управляющих элементов - блоков регулятор, кнопка, константа. Кроме того, переход на другой уровень блок-схемы (для которого не активирован режим) позволяет вносить любые изменения. После выполнения и просмотра анимации обновить вид рабочего поля можно командой меню Правка > Обновить экран.

Анимация управляется посредством подаваемых на соответствующий блок сигналов. Сигналы определяют номер визуализируемого рисунка (кадра) и его положение (координаты) на экране. Например, рассмотрите анимацию падения мяча:

Демонстрация анимации посредствам изменения координат одного кадра

Можно заметить, что данная анимация использует только один кадр мяча, но меняются его координаты при активированной опции "Оставлять след анимации". Использование совокупности кадров позволило бы дополнительно показать вращение мяча. А если воздействовать на обрезающие размер кадра аргументы "w" "h" блока анимация, то возможно создание эффекта приближения.

Добавление изображений в блок 'анимация'

Кадры изображений, которые Вы можете подключить к блоку анимация должны являться BMP-файлами растровой графики с количеством цветов не более 256. Для создания BMP-файлов рекомендуется использовать стандартное Windows-приложение - графический редактор Paint.

Для добавления изображений в блок анимация выполните действия:

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к блоку анимация и нажмите кнопку мыши. Должно появиться диалоговое окно "Свойства анимации".
  3. В строке ввода "Количество кадров" (Number of States) введите необходимое число изображений. Вы можете подключить не более 16 BMP-файлов.
  4. В списке выбора "Кадр:" укажите "state0".
  5. Выполните любую последовательность действий:
  6. Если требуется подключить второе изображение, то в списке выбора "Кадр:" укажите "state1" и повторите действия пункта 5. Затем, аналогично, указывая соответствующий кадр, подключите все BMP-файлы.
  7. Нажмите на кнопку OK или клавишу ENTER.

Выполнение анимации

Внешний вид блока анимация при установке его в блок-схемуСигналы, поданные на входы блока анимация, управляют одноименным процессом в течение симуляции модели. Блок анимация имеет пять входных сигналов:

Все координатные преобразования Вы должны осуществлять вручную посредствам библиотечных блоков.

Создание следа анимации

Для включения режима, в котором остается след анимации, выполните действия:

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к блоку анимация и нажмите кнопку мыши. Должно появиться диалоговое окно "Свойства анимации".
  3. Активируйте опцию "Оставлять след анимации"
  4. Нажмите на кнопку OK или клавишу ENTER.

Использование блока 'анимацияЛинии'

Рабочий файл [fir.vsm]

Блок анимацияЛинии оптимально подходит для создания визуализации движения рычажных механизмов, но возможны и другие варианты. Четыре входа позволяют управлять координатами начала и конца отрезка линии. Вы можете установить толщину отрезка, стиль и цвет в диалоговом окне "Свойства линии".

Порядок обращения к диалоговому окну "Свойства линии":

  1. Выберите команду меню: Правка > Свойства блока.
  2. Указатель мыши, который должен был смениться на гаечный ключ, подведите к блоку анимацияЛинии и нажмите кнопку мыши. Должно появиться диалоговое окно "Свойства линии".
  3. Выполните коррекцию необходимых опций.
  4. Нажмите на кнопку OK или клавишу ENTER.

Диалоговое окно 'Свойства линии'

Опция

Описание

Толщина

Введенное в этой строке ввода число, определит толщину линии. Значение по умолчанию 1 пиксель дисплея

Стиль

Используя этот выпадающий список, можно назначить требуемый стиль линии: монотонная (Solid), пунктирная (Dash), штрих-пунктирная (Dash-Dot), ...

Цвет

Нажатие на эту кнопку вызывает открытие системного диалогового окна "Цвет". С его помощью, в предложенной палитре, Вы можете выбрать требуемый цвет для оформления линии

Управление движением линии

Внешний вид блока анимацияЛинии при установке его в блок-схемуПодобно блоку анимация, блок анимацияЛинии использует входные сигналы, для создания эффекта движения. Верхние входы "x" и "y" определяют координаты одного конца анимируемого отрезка линии. Одноименные нижние входы - определяют координаты второго конца. Меняя значения этих управляющих сигналов, Вы создаете эффект движения.

Нулевым координатам соответствует верхний левый угол рабочего поля. Координаты увеличиваются к нижнему правому углу. Для отображения анимации на большинстве мониторов, рекомендуется придерживаться видеорежима  VGA (640x480). Единица измерения координат - один пиксель дисплея.

Другие способы создания анимации

Блоки пробник и кнопка обладают анимационными возможностями, которые можно назвать альтернативными. Блок панель рекомендуется использовать для создания требуемого фона.