Вставка, настройки, соединение блоков

Библиотека блоков - обзор

Программа VisSim позволяет Вам строить модели систем, составляя их блок-схемы. Блоки - это "кирпичики" Вашего проекта. Каждый блок реализует определенную математическую функцию. Функция может быть простой, как функция синуса или сложной, как передаточная функция (ПФ) скажем 15-ого порядка.

VisSim располагает библиотекой более чем из 90 блоков для построения линейных, нелинейных, параметрических, непрерывных, дискретных или гибридных систем. В библиотеке соблюден баланс между количеством блоков и удобством в построении моделей. Все блоки доступны через меню Блоки. В нем они упорядочены в группы следующим образом:

Дополнительно в библиотеке VisSim-а имеется пять блоков специального назначения:

Если Ваша модель требует специфический блок, отсутствующий в библиотеке, Вы можете создать его с применением языков программирования: Си, Си++, ФОРТРАН или Паскаль; и подключить его, применяя блок "DLL-функция". См. приложение B Руководства пользователя VisSim-а.

Вставка блоков

Установить блок на рабочее поле можно двумя способами:

Идентифицирующие элементы блоков

Когда Вы устанавливаете блок на рабочее поле блок-схемы, различные символы и текст появляются на нем (позиционируйте указатель мыши над элементами рисунка).

#########

Треугольники по сторонам блоков определяют входы и выходы для прохождения сигналов. Около контактов блоков могут присутствовать их имена для идентификации позиции сигналов в функции преобразования.

Отображение дополнительной информации о блоке

Вам доступна возможность отображения имен, значений параметров или имен файлов ниже каждого блока.

Для отображения имен блоков выполните действия:

  1. Выберите команду меню Правка > Настройки.
  2. В диалоговом окне выберите вкладку "Глобальные настройки среды".
  3. Активизируйте опцию "Метки режима 'Обучение' " и нажмите на кнопку OK или клавишу ENTER.
  4. Выберите команду меню Вид > Параметры блоков. Галочка перед командой указывает, что режим визуализации блочных меток или параметров включен.

Для отображения значений параметров блоков и их имен файлов выполните действия:

  1. Выберите команду меню Правка > Настройки.
  2. В диалоговом окне выберите вкладку "Глобальные настройки среды".
  3. Деактивируйте опцию "Метки режима 'Обучение' " и нажмите на кнопку OK или клавишу ENTER.
  4. Выберите команду меню Вид > Параметры блоков. Галочка перед командой указывает, что режим визуализации блочных меток или параметров включен.

Установка параметров блоков

Большинство блоков имеет устанавливаемые пользователем параметры, которые должным образом определяют их функции преобразования. Определить или изменить значения параметров Вы можете посредствам одноименных диалоговых окон ("Properties"). Если Вы поменяете параметры в момент выполнения симуляции, VisSim немедленно использует новые значения для отражения изменений. Начальные условия, которые устанавливаются в модели (обычно на блоках: "1/S", "S&H", "1/Z", "e-sTd") в начале симуляции, также задаются через диалоговые окна блоков ("Properties").

Для определения / изменения значений параметров блоков, опций или имен их файлов выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мышки сменится на гаечный ключ).
  2. Укажите мышкой блок, параметры которого Вы хотите редактировать.
  3. В диалоговом окне "Properties", зафиксируйте свои установки.
  4. Нажмите на кнопку OK или клавишу ENTER.

Быстрый доступ к диалоговым окнам "Properties" для большинства блоков возможен посредствам простого указания блока с помощью другой клавиши мыши. Не большое количество блоков: button, compound, DDE, DDEsend, DDEreceive, embed, label, userFunction, и variable - имеет либо два диалоговых окна, либо поддерживает дополнительные команды мыши. Быстрый доступ к их диалоговым окнам "Properties", посредствам другой клавиши мыши, возможен при удержании клавиши CTRL.

Ввод числовых данных

При вводе числовых данных, VisSim отображает значения большие, чем 106 или меньшие чем 10-6 в показательной форме. VisSim использует латинскую букву "e" (или "E"), для отделения мантиссы от степени. Например, Вы можете вводить число 6.000.000,0 следующими способами: 6e6 или 6E6.

Ввод арифметического выражения

Бывает очень удобно вводить числовые данные в параметры блоков с помощью простых математических выражений. Допустимо использование арифметических операторов: "+", "-", "*", "/"; константы "pi"; функций и обычных правил приоритетов в расчетах.

Например:

Ввод 'Си'-выражения

В строках ввода числовых данных VisSim способен распознать выражения, написанные на языке Си, результат которых числовые данные. Те Вы можете использовать элементарные математические функции: acos, asin, atan2, cos, cosh, exp, fabs, log, log10, pow, sin, sinh, sqrt, tan, и tanh. Например, если Вы введете "pow(2,3)" вместо коэффициента усиления в одноименном блоке (gain), то VisSim его вычислит (8) и примет к исполнению. VisSim также интерпретирует символы "pi", как универсальную константу 3,1415926... . Синтаксис языка Си обычно хорошо изложен в любой книге по ОСНОВАМ языка Си.

Назначение количества индицируемых знакомест

Числовые расчеты модели всегда проводятся программой VisSim с точностью до 15-и значащих десятичных цифр (речь о мантиссе). Однако, Вы при визуализации, Вы можете ограничить мантиссу с 15 до 6 значащих десятичных цифр.

Для переключения размера мантиссы для визуализации цифр выполните действия:

  1. Выберите команду меню Правка > Настройки.
  2. В диалоговом окне выберите вкладку "Глобальные настройки среды".
  3. Установите опцию "Большая дискретность у регуляторов" в требуемое значение. Активация опции заставит VisSim визуализировать 15 значащих десятичных цифр. Деактивация обрежет мантиссу визуализации до 6 знакомест.
  4. Нажмите на кнопку OK или клавишу ENTER.

Описанное действие опции "Большая дискретность у регуляторов" является дополнительным.

Идентификация блоков метками пользователя

Для большинства блоков, в диалоговом окне настройки параметров ("Properties"), может быть определена текстовая метка. Когда активизирован соответствующий режим отображения блок-схемы (меню - Вид > Параметры блоков), метки появляются ниже соответствующих блоков вместо их параметров. Определение метки демонстрирует рисунок.

#########

В диалоговом окне, метка "Волна" назначена одному из блоков синусоидального сигнала. При перемещении блока, метка автоматически перемещается с ним. Метки можно использовать для поиска положения блока командой меню Правка > Найти.

Для маркировки блоков выполните действия:

  1. Выберите команду меню Правка > Свойства блока (курсор мышки сменится на гаечный ключ).
  2. Укажите мышкой блок, у которого Вы хотите определить метку.
  3. В поле "Метка" введите идентифицирующий текст, который не может быть длиннее строки ввода (если Вы нуждаетесь в более длинном тексте, используете блок "метка" из меню Блоки > Аннотационные).
  4. Нажмите на кнопку OK или клавишу ENTER.
  5. Активизируйте режим отображения меток и параметров блоков командой меню Вид > Параметры блоков. Галочка перед командой указывает, что режим визуализации блочных меток или параметров включен.

Соединение блоков - обзор

Соединение блоков проводниками, указывает VisSim-у,   в какой последовательности и какому блоку передать сигналы для обработки в течении симуляции модели. Сигналы - это просто данные (значения координат модели). Ко входным сигналам (xn) относятся те, что поступают на входы блоков; выходные сигналы  (yn) присутствуют на их выходах.

В VisSim-е имеется два типа проводов:

Простой проводник (FlexWire) - это тонкий провод, который позволяет передать только один сигнал (координату) между блоками. Шинный проводник, на экране более толстый он содержит множество простых проводников и позволяет передавать совокупность сигналов. Шинные проводники используются при выполнении векторных или матричных операций, или же в целях повышения наглядности проекта (не загромождения блок-схемы на верхнем уровне). В таблице перечислены блоки, к которым подключаются шинные проводники.

Категория блоков

Имена блоков

Аннотационные

index, scalarToVec, variable, vecToScalar, wirePositioner

Арифметические

1/X, -X, *, /, abs, convert, gain, power, sign, summingJunction, unitConversion

MatLab Интерфейс

MatLab Expression, MatLab Read Variable, MatLab Write Variable

Матричные операции

buffer, dotProduct, fft, ifft, inverse, multiply, transpose, vsum

Нелинейные

case, merge

Приборы и Датчики

display

Собрать одиночные проводники в шину и вывести их из нее можно при помощи парных блоков scalarToVec и vecToScalar соответственно.

Удобной альтернативой для передачи сигналов может являться возможность использования определяемых пользователем переменных. Этот механизм подобен использованию символа заземления в схемах электрических принципиальных и его главное достоинство аналогично - повышение наглядности блок-схемы за счет сокращения загромождающих ее проводниковых связей. Для получения дополнительной информации, см. раздел Передача сигналов переменными.

Правила соединения блоков проводниками

Вы можете прикреплять проводники и шины к выводам блоков. Как только Вы подключили провод к блоку, VisSim принимает связь и обслуживает ее в дальнейшем. Если Вы перемещаете блок по рабочему полю, проводники автоматически перерисовываются и не отключаются.

Когда Вы соединяете блоки, действуют следующие правила:

Треугольная форма оформления выводов, указывающая направление прохождения сигналов, позволит Вам легко отличить входы от выходов. Только применяя блок "фиксаторПровода" Вы можете определить необходимое Вам положение проводника на блок-схеме. О изменении количества выводов у блока, см. раздел: Добавление / удаление выводов у блоков.

Для соединения блоков выполните действия:

  1. Подведите указатель мыши к выводу блока (желательно к выходу), который вы хотите соединить с другим выводом. Вид указателя должен смениться на стрелку Данный вид указателя мыши сообщает о возможности работы с выводом блока .
  2. Удерживая кнопку мыши, перетащите указатель с проводником к выводу блока назначения.
  3. Находясь в области подключаемого вывода, отпустите клавишу мыши.

В момент выполнения операции, когда Вы перетаскиваете указатель, VisSim генерирует мерцающую линию, которая является проводником. VisSim рисует проводники только под прямыми углами, поэтому проводник не повторяет путь курсора.

Авто-связывание выводов блоков

Для облегчения процесса соединения блоков проводниками определен радиус зоны с центром на выводах блоков. При доведении проводника до этой зоны происходит подключение. Если зоны входов и выходов перекрываются, то для их соединения достаточно просто указать мышкой любой из выводов.

Для коррекции "Радиуса авто-соединения" выполните действия:

  1. Выберите команду меню Правка > Настройки.
  2. В диалоговом окне выберите вкладку "Глобальные настройки среды".
  3. В строке ввода "Радиус авто-соединения", введите значение в дюймах.
  4. Нажмите на кнопку OK или клавишу ENTER.

Блок 'фиксаторПровода'

Применяя блок "фиксаторПровода" Вы можете повысить наглядность вашей блок-схемы, качественным образом размещая проводники на блок-схеме. Типовой случай - передача сигнала единичной обратной связи (ОС) на вход чувствительного элемента (на главный сумматор). Меняя положение блока "фиксаторПровода" Вы будете определять положение проводника.

Блок "фиксаторПровода" не выполняет преобразований сигналов и не требует дополнительного времени при симуляции модели. Через блоки "фиксаторПровода" могут быть направлены как обычные проводники, так и шины.

Цветовая раскраска проводников

Для изменения цветовой раскраски всех проводников блок-схемы выполните действия:

  1. Выберите команду меню Вид > Цвет.
  2. В диалоговом окне "Выбор цвета" в выпадающем меню "Линии связи" нажмите кнопку СТРЕЛКА ВНИЗ.
  3. Выберите желаемый цвет.
  4. Нажмите на кнопку OK или клавишу ENTER.

Дополнительно Вам доступна возможность изменения цвета определенных проводников. Для этого вам необходимо назначить "Класс соединения" соответствующим выводам блоков, см. раздел: Создание классов проводников и изменить его цвет.

Скрытие проводников

При активизации режима "Дисплей оператора", VisSim скрывает все проводники. Этот режим предназначен для отображения контрольной или контрольно-измерительной панели без проводниковых связей или когда Вам требуется визуализировать анимацию.

Для скрытия проводников выберите команду меню Вид > Дисплей оператора. Галочка перед командой указывает, что режим "Дисплей оператора" включен.

Удаление проводников

Для удаления проводника необходимо отделить его от входа блока, к которому он подключен:

  1. Укажите мышкой подключенный вход.
  2. Удерживая кнопку мыши (взяв проводник), отведите указатель на свободное поле блок-схемы и бросьте проводник (отпустив кнопку мыши).

Выводы блоков - обзор

Все блоки, которые обрабатывают сигналы в VisSim-е, имеют выводы. VisSim различает входы и выходы и обслуживает их по-разному. Входы предназначены для передачи сигналов функциям преобразования блоков. На выходы поступают результаты выполнения блочных функций. Треугольная форма оформления выводов (контактов) блоков позволяет Вам легко проследить направления распространения сигналов по блок-схеме.

Некоторые блоки имеют символы над выводами, которые указывают тип данных или каким образом блочные функции обрабатывают сигналы. Например, "-" над входом блока "сумматор" означает инверсию сигнала. См. индивидуальные описания блоков для ознакомления с идентифицирующей сутью символов контактов.

Добавление / удаление выводов у блоков

Вы можете добавлять или удалять выводы у большинства блоков VisSim-а. Если на момент удаления вывода к нему подключен проводник, то он так же будет удален с блок-схемы. Не забывайте достраивать внутреннюю структуру составных блоков, которым вы добавляете новые контакты. Вы можете назначать имена выводам составных блоков, см. раздел: Назначение имен выводам составного блока.

Для добавления / удаления вывода блока выполните действия:

  1. Воспользуйтесь необходимой кнопкой Добавить выводы блоку Удалить выводы блока в инструментальной панели "Главная"; или выберите команду меню Правка > Добавить вывод / Удалить вывод. Указатель мыши приобретет вид, подобный изображениям на показанных кнопках.
  2. Подведите указатель к выводам блока. Под новым видом указателя мыши будет появляться горизонтальная черточка (при добавлении выводов) или выводы блоков будут выделяться пунктирным прямоугольником (при удалении выводов).
  3. Определитесь с местом добавления вывода или с удаляемым выводом и нажмите клавишу мыши.
  4. Можете повторить шаги 2 и 3.
  5. Переместите указатель мыши на пустое место блок-схемы и нажмите клавишу мыши для завершения операции.

Создание классов соединений

Классы соединений обеспечивают ассоциативное оформление расчетов координат в блок-схеме по именам и цвету. Определить и назначить класс для соединений можно посредствам диалогового окна "Настройка выводов / соединений". Для его вызова следует дважды щелкнуть мышью по выводу блока.

Настройка выводов / соединений

Класс соединения определяется его именем и цветом проводников. Например, Вы можете назначать имя класса "Температура" тем цепям блок-схемы (выходам), которые связаны с расчетом температурных координат. Если класс назначен определенному выходу, то куда бы он ни был подключен - проводники будут окрашены в цвет класса.

Для определения или назначения класса для соединений выполните действия:

  1. Подведите указатель мыши к классифицируемому выводу. Вид указателя должен смениться на стрелку Данный вид указателя мыши сообщает о возможности работы с выводом блока .
  2. Осуществите двойной щелчок мышью - должен появиться диалог "Настройка выводов / соединений" (может мешать большой радиус авто-соединения).
  3. В строке ввода "Имя класса" введите название (для определения нового класса) или нажмите на кнопку СТРЕЛКА ВНИЗ для назначения существующего.
  4. В палитре "Цвет проводника" нажмите на кнопку СТРЕЛКА ВНИЗ и выберите цвет.
  5. Нажмите на кнопку OK или клавишу ENTER.

Для изменения цветовой раскраски проводников класса выполните действия:

  1. Подведите указатель мыши к любому выводу, который подключен к классу проводников. Вид указателя должен смениться на стрелку Данный вид указателя мыши сообщает о возможности работы с выводом блока .
  2. Осуществите двойной щелчок мышью - должен появиться диалог "Настройка выводов / соединений" (может мешать большой радиус авто-соединения).
  3. В палитре "Цвет проводника" нажмите на кнопку СТРЕЛКА ВНИЗ и выберите цвет.
  4. Нажмите на кнопку OK или клавишу ENTER.

Ограничение подключений к цепи класса

Если Вы хотите предотвратить случайные подключения между разными классами цепей блок-схемы, активизируйте опцию "Ограничить подключения к элементам класса" в диалоговом окне "Настройка выводов / соединений" (см. выше).